Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!)



  • @roslof Yes, is that repo but it´s not uploaded into my gitgub branch so I have to wait until Nik, who is in charge of that part to uploade them! I hope he soon will apply the changes!



  • Hi
    I'm sorry, but I didn't understand how to add these scripts ... do I have to copy them manually into the Retropie folders?

    Among the Libretro cores, there is also that of Thomson, which could be an interesting addition



  • @hermit follow here to install, basically you have to replace your Retropie-Setup folder with mine.

    Sure if Thomson MO5 is supported by MESS i can add it. i'm following this theme from Hursty and adding what i find is supported.



  • @valerino said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    @hermit follow here to install, basically you have to replace your Retropie-Setup folder with mine.

    Sure if Thomson MO5 is supported by MESS i can add it. i'm following this theme from Hursty and adding what i find is supported.

    thank very much :)
    I meant this core https://libretro.readthedocs.io/en/latest/library/theodore/ for Thomson T08



  • @hermit said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    https://libretro.readthedocs.io/en/latest/library/theodore/

    Here you are, news of today:

    • added lr-mess-mo5 (Thomson MO5, fully working)
    • added lr-mess-to8 (Thomson MO8, working, no sound)
    • added lr-mess-vg5000 (Philips VG-5000, fully working)

    can somoeone .i.e @roslof , @chicuelo provide themes for mo5 and to8 ? they're missing in Hursty themes afaik.



  • I've been using your shell scripts as templates to add additional MESS systems as well.

    Here's a few that I've added.

    folder - name - parameter
    gamate BitCorp Gamate -cart
    sorcerer Exidy Sorcerer -cass1
    fm7 Fujitsu FM7 -cass and -flop1
    vc4000 Interton VC 4000 -cart
    mz700 Sharp MZ-700 -cass
    mz2500 Sharp MZ-2500 -flop1
    svi328 Spectravideo -cass
    tutor Tomy Tutor -cart

    Thanks for laying the groundwork down with your shell scripts!
    For Spectravideo, I’ve had the best luck using the “svi328” instead of “svi318”.



  • @dmmarti awesome ! can you please clone my git repo, add your scripts, and issue me a pull request ? thanks!!!!

    some i just added myself

    • lr-mess-fm7 (Fujitsu FM7, fully working)
    • lr-mess-multivision (Othello Multivision, fully working)
    • lr-mess-mz700 (Sharp MZ700, fully working)
    • lr-mess-svi318 (Spectravideo 318/328, fully working)
    • lr-mess-vc4000 (Interton VC4000, partially working)

    i also added the new version of dosbox:

    • lr-dosbox-svn


  • @valerino So I took the plunge and finally decided to install your script. I followed the instructions on this page to the letter : link text

    I manage to launch the script but I can't see any new packages/modules anywhere. Am I missing something?



  • I'm not sure if this will be of any use at all, but there was work on some of these emulators (e.g. BBC's beebem), done in the past, in the (now abandoned) Zerojay RP Extra repository - https://retropie.org.uk/forum/topic/8/retropie-extra-repository



  • @Zering you probably haven't followed the instructions well.

    # make backup of your existing retropie-setup
    cd /home/pi
    mv ./RetroPie-Setup ./RetroPie-Setup.bck
    
    # now clone mine in place of the original
    git clone https://github.com/valerino/RetroPie-Setup
    
    # now proceeed as normal running retropie_setup.sh
    sudo ~/RetroPie-Setup/retropie_setup.sh
    

    cheers!



  • @valerino Whenever I use the second command, it says RetroPie-Setup is not a valid directory, or that it cannot write over the existing file.

    Also I'm pretty positive I saw your RPS get cloned yesterday, but my RetroPie-Setup shows as unchanged in WinSCP ; the last changes are from the 28th.

    I'll try again and let you know.

    Edit : I tried again and I get the following error after typing in the second command :

    fatal : Not a git repository (or any of the parent directories): .git

    Edit 2 : Does lr-mess have to have been installed from source for this to work? Or will a binary install do?



  • @Zering wtf...... ure right :) my bad, i mistyped. its obviously 'git clone' not 'git pull' !!! i corrected the post above.

    about lr-mess, i had to install it from source, didnt find the option to install from binary in the retropie menu. anyway, it deosnt matter if you install from binary or source, except the latter takes about 3hrs on an rpi4 (and significantly longer on rpi3, i presume....).



  • @valerino I can't even compile from source on my rpi3, it never finishes building. I'm glad to hear it can work from binary. But your previous guide says that installing the 'fake cores' is done through the 'install from source' option? Can you clear that up?



  • @Zering one thing is to install lr-mess itself (which, as i said, you can do from binary or sources, as you prefer).
    another thing is to install the fake cores, which depends from lr-mess (indeed, they check for lr-mess installed in their install procedure, and exit if not found).
    you see 'install from source' in the fake cores because that's what the retropie install script display by default (i never thought of changing it....), just click it.

    'fake cores' do not install anything, they just create and setup a separate lr-mess configuration to trick emulationstation/retroarch that the lr-mess system you're going to install is a separate independent core (which is not).



  • @valerino So where do the 'fake cores' appear once I run your script? I can't find them in the main, optional, experimental or even the core modules.
    I tried your commands again, even after your edit, and I still get a fatal error report. However, when I follow the instructions on your github, I see your repository being cloned, but I can't see anything beyond that after I run the script.



  • @Zering the fake cores are under experimental, right after lr-mess. they're called lr-mess-blabla.
    sorry, but it's surely something your side, i can't know :(
    the instructions here https://retropie.org.uk/forum/post/219892 are the only thing you need to setup everything.



  • @valerino Hi, I've installed the lr-vice-xvic scriptmodule. It works fine with tapes and disks, but I can't make it work with cartridges. Is there a specific setting that I'm missing?



  • @saccublenda hi, this is dependent on vice itself, it has nothing to do with the lr-vice setup script. try others, i experimented that myself, some carts works and some not. there may (i haven't checked deeply) be core options in lr-vice affecting it, they may be set via command line options (so you could theoretically modify the installer script to add them), but i sincerely don't know. just experiment yourself :)



  • @valerino It is indeed a problem of lr-vice itself.
    When you install vice it creates several emulators, including vice-x64 (which just runs vice.sh x64 %ROM%), vice-xvic (which runs vice.sh xvic %ROM%), and vice-xvic-cart (which runs vice.sh xvic %ROM% -cartgeneric).
    The Vic-20 cartridges so run fine with vice-xvic-cart, and lr-vice runs fine C64 cartridges, but it fails to run Vic-20 cartridges.



  • This has my hopes up to play a couple of bbc games.
    I’ve followed the instructions, but I fear my bios files for bbc may not be correct. Whenever I try to start a game I just get a white outline box with a tiny word (which I can’t read because it’s a small screen) and cannot do anything from there. Can anyone confirm the md5sum for bbcb.zip, bbcbp.zip, bbcbp128.zip and saa5050.zip?
    I have to reboot the system each time I try:(



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.