Please do not post a support request without first reading and following the advice in

new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!)

  • @valerino So where do the 'fake cores' appear once I run your script? I can't find them in the main, optional, experimental or even the core modules.
    I tried your commands again, even after your edit, and I still get a fatal error report. However, when I follow the instructions on your github, I see your repository being cloned, but I can't see anything beyond that after I run the script.

  • @Zering the fake cores are under experimental, right after lr-mess. they're called lr-mess-blabla.
    sorry, but it's surely something your side, i can't know :(
    the instructions here are the only thing you need to setup everything.

  • @valerino Hi, I've installed the lr-vice-xvic scriptmodule. It works fine with tapes and disks, but I can't make it work with cartridges. Is there a specific setting that I'm missing?

  • @saccublenda hi, this is dependent on vice itself, it has nothing to do with the lr-vice setup script. try others, i experimented that myself, some carts works and some not. there may (i haven't checked deeply) be core options in lr-vice affecting it, they may be set via command line options (so you could theoretically modify the installer script to add them), but i sincerely don't know. just experiment yourself :)

  • @valerino It is indeed a problem of lr-vice itself.
    When you install vice it creates several emulators, including vice-x64 (which just runs x64 %ROM%), vice-xvic (which runs xvic %ROM%), and vice-xvic-cart (which runs xvic %ROM% -cartgeneric).
    The Vic-20 cartridges so run fine with vice-xvic-cart, and lr-vice runs fine C64 cartridges, but it fails to run Vic-20 cartridges.

  • This has my hopes up to play a couple of bbc games.
    I’ve followed the instructions, but I fear my bios files for bbc may not be correct. Whenever I try to start a game I just get a white outline box with a tiny word (which I can’t read because it’s a small screen) and cannot do anything from there. Can anyone confirm the md5sum for,, and
    I have to reboot the system each time I try:(

  • Hi

    how straightforward is it to add Atom, Apple 1 and 3 and other machines via mess, and your script? No doubt I can run it via mess but i thought i'd ask if there was a self-serve option, or, if you please had plans to add others to your script?

    thank you v much for what you've done! adding the 2 casio PV's and apple2 GS to my pi 3 now - thanks again!

    (BTW! I've had bbc micro and electron working pretty well via advmame /advmess for some time inc sound, and auto-loading disk and tapes. There's a thread on retropie forums about it, if the issue with sound here isn't resolved. Atom,I've never got working right in advmame)


  • does lr-mess emulate the sharp x1? if so, is there some guidance someone could point me to? i've been using lr-x1, but i have some roms that won't open in that emulator and looking for other emulator options.

  • This is really nifty, nice job @valerino!

    For anyone who wants to play Arcadia, Creativision and Astrocade stuff I walked through button mappings here: (scroll down past the MESS setup instructions).

  • @roslof
    Can you provide a checksum for your MESS BIOS files for the TI99/4A?

    I've been working on getting the *.rpk files running. They start just fine and I get the main screen where I have to pick a number for the game. So at that point, everything works good.

    After I chose, it just goes to a blank teal screen and sits there, the actual game never starts.

    I'm thinking it's a BIOS problem. I've tried a few different ZIP BIOS files from various MAME/MESS versions .. but so far, I've not have any luck.

  • @dmmarti no problem, but to me, it sounds more like a symptom of the .rpk itself. You've tried multiple from different sources?

    Here are the BIOS md5 checksums:

    19350381a062a70feff18748eb6692fa \retropie\bios\
    26e6f317aff0f120cea2d7bcf69c3a6b \retropie\bios\
    92a4ac9559874cf7116709421d8ba63d \retropie\bios\

    Of course, these are ZIPs of several files, so possible the checksums will be different if ZIP itself was compressed with a different tool or compression method.

    FWIW: My file contains:
    folder: ti99_4ev
    folder: ti99_4qi
    file: 994a_grom0.u500
    file: 994a_grom1.u501
    file: 994a_grom2.u502
    file: 994a_rom_hb.u610
    file: 994a_rom_lb.u611

    Hope this is helpful.

  • @roslof Thanks!

    I haven't tried other *.rpk files as the ones I have work with stand alone MESS.

    I'll verify my BIOS files versus yours and hunt down some other game files.


  • @valerino I have got to ask Can you add a script for the Atari Jaguar CD? Also this has answered some of my prayers. Can't thank you enough.

  • hello

    I have a pi4, and am having difficulty installing at least GSplus from from repo (details copied below, from your post just above). Please can someone help advise what I am doing wrong and what is the fix?

    Pi4, official retropie build.

    switch to your repo, git clone (as below)

    install gsplus from experimental


    emulationstation will no longer boot. get this error in the shell:

    Creating config directory "/home/pi/.emulationstation"
    Config directory could not be created!

    if I go look in /opt/retropie/ the configs folder is now missing

    there are now 2 folders, configs.crt and configs.hdmi. its possible, but unverified, its renaming my config folder and breaking startup.

    there is a symlink for 'configs' pointing to, I think, configs.hdmi

    however it will no longer run emulationstation

    my pi4 btw, connects to a screen using a hdmi to DVI cable with audio from the 3.5mm jack. I have no choice.

    *EDIT: just tried again, installing one of the mess scripts causes the same error.

    EDIT2: brand new retropie buster image for pi4 off the retropie site. different micro sd card. added wifi. swapped to the git as per instructions. installed lrmess. reboot.ok. installed a mess script - no longer boots to emulationstation. opt/ retropie/configs is no longer there. configs.crt and configs.hdmi are there.*

    why is this?

    @valerino said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    make backup of your existing retropie-setup

    cd /home/pi
    mv ./RetroPie-Setup ./RetroPie-Setup.bck

    now clone mine in place of the original

    git clone

    now proceeed as normal running

    sudo ~/RetroPie-Setup/

  • Narrative continues:

    Over on github i see this in the readme. Sorry I didnt see this in this thread.



    • CRT/HDMI: provides autoconfiguration of HDMI or CRT/PAL/NTSC outputs, needs reboot. this currently needs my retrovpie configuration to work correctly.

    I hadnt seen that, so as well as gsplus and mess, it automatically changes hdmi/crt configs without any user request? I'll go look now. I definitely had not executed such an option.

    has anyone had such a problem? I'm stuck

  • @roslof

    I would love those .gsp if I can get them.

    I am having problems gett lr-mess-apple2gs t work. When I run it says initialization and just gets stuck on that screen. Any suggestions?

  • @roslof if you could be a star and please share those .gsp files? dropbox or google or other? I know these were for the standalone gs, but I have to get it working.

    thanks if thats possible it'd be a great resource.

    thank you!

  • @iainjh @pacpir Hmmm. A few things you'll need to know, since a .gsp (GSPlus configuration file) doesn't solve everything. You'll need to be sure everything is named correctly and in its place. A lot of this information is in an earlier post.

    For any of my .gsp configuration files to work for you, you'll either need to edit them, or create this exact structure:

    1. GSP Location: ~/RetroPie/roms/apple2gs/
    2. IIGS 2mg files (unzipped): ~/RetroPie/roms/apple2gs/[Disk Images]/
    3. GSOS6.0.1.img location: ~/RetroPie/roms/apple2gs/

    For #2, the EXACT file names required are listed in each .gsp file. Rename accordingly.

    For #3, some games require a HD image with OS 6.0.1 installed. you'll likely need to create the hard drive image manually. It's a bit of a pain, but there are videos describing the process.

    LINK TO GSP (GSPlus Configuration) FILES

    Other Notes:

    WARNING: Never launch non-gsp files! GSPlus will assume any referenced file is a gsp configuration file and treat it as such. CLARIFYING: If you try to launch a .2mg file or .zip file with this method, it will CORRUPT it and you'll need to replace it with the original. So use care. You may opt to remove .zip and .2mg references from your es_settings.cfg if you're otherwise worried about this.

    DO NOT USE ROM3. ONLY USE ROM1. Some games are otherwise incompatable. ROM1 works with everything.

    If you cannot see the .gsp files in EmulationStation, then you'll need to add the .gsp extension to your es_systems.cfg file. If you're not going to use lr-mame for IIGS, then I recommend removing .zip and .2mg from es_systems.cfg (see "WARNING" above).

    I use a DualShock 4 controller to play games. In each gsp you'll notice these lines:

    g_joystick_scale_factor_x = 281
    g_joystick_scale_factor_y = 281

    Remove them if they cause trouble with your controller, or override them with GSPlus F4 settings.

    Here is the VERY simple emulation.cfg info for the emulator:

    gsplus = "/opt/retropie/emulators/gsplus/ %ROM%"
    default = "gsplus"

    Hope this helps.

    @roslof if you could be a star and please share those .gsp files?

    @iainjh now that I'm "a star", you owe me a beer.

  • Roslof, thank you! We have beer on tap, just pop round:)

    Thats a fantastic resource, and the guide. Thanks again for sharing. iain

    I'll get that set up, once I've rebuilt my setup without the config.hdmi folder messup above. CURRENT STATUS as of sunday: I used a new retropie buster, connected to the github, installed all the scripts as before, the config.hdmi and config.crt appeared and retropie no longer starts ES. FTP'ed out the stubs/Lr-mess fake emulator folders, config folders, emulator.cfg's and run_mess script. FTP'ed those over to a booting build so as not to break ES, and apple 1 at least boots so that is progress! Several other setups - coco etc - presently stick mid-boot with a distorted 'initialising' message, I'll check the BIOS locations are correct.

  • @iainjh said in new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!):

    I'll check the BIOS locations are correct.

    If it helps, ROM.01 must be renamed (or be symlinked) as a file called "ROM" that lives with the executable.

    Here is how mine is setup (as I like all BIOS for all systems in the same location):

    GSplus executable location:

    Symlink GSplus ROM (bios):
    /opt/retropie/emulators/gsplus/ROM (points to "Actual path" below)

    Actual path of ROM (bios):

    So, basically, the GSplus executable directory should look something like this:

    -rw-r--r--   pi   pi    config.gsp
    -rwxr-xr-x   pi   pi    GSplus
    -rwxr-xr-x   pi   pi
    drw-r--r--   pi   pi    lib
    -rwxr-xr-x   pi   pi    partls
    -rw-r--r--   pi   pi    retropie.pkg
    lrwxrwxrwx   root root  ROM -> /home/pi/RetroPie/BIOS/apple2gs/ROM.01

    ...or just rename ROM.01 to ROM and put it in this folder if you don't want to deal with symlinks.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.