Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

new scriptmodules (lr-vice-xvic, gsplus, proper lr-mess integration!)



  • @roslof yep, my scripts have their limits :( of course they can be improved, but definitely multi-disk support must be implemented by the emulators .....

    really, it's more of a problem of the frontend. my scripts can be changed in 2 minutes to support 2 or more disks, but someone needs to pass the parameters to the scripts .... and this is the frontend (emulationstation, in this case).
    you can surely run apple2gs games from command line using -flop1, -flop2, etc... using run-mess.sh. but that won't work from emulationstation, since it passes one disk only to the script.

    anyway, from what i see i'm pretty confident i can make scripts for almost every lr-mess system with this technique, its somewhat generic :)



  • Oh! @valerino don't get me wrong, man. Wasn't at all being critical. I don't think it's a script issue here, rather I think there are limitations in MESS. As it stands, I'm using GSPlus with very good success so far.

    Been hoping for IIGS emulation on the Pi since I fist picked this up in 2017. Stoked that it's now a reality and actually running in my home.

    Like you, I'm a huge fan of using RetroArch when possible (tons of benefits). So I'm hoping for ~80% compatibility there, and I'm all but certain the joystick will work. :)

    Great work on giving us more things to play with. Enjoying.



  • added TRS-80.

    f4dd05c8-2af9-463e-96cb-09753885f851-image.png



  • added Emerson Arcadia 2001

    https://github.com/valerino/RetroPie-Setup/blob/master/scriptmodules/libretrocores/lr-mess-arcadia.sh

    btw .... would any of you mind to give me some feedback using my repo ? i had to cancel a pull request i made on the official github since a guy had problems running my run_mess.sh script (some problems with bash). i couldn't replicate it, so i'd really like to have some feedback to better investigate!

    cheers!



  • I'm using the latest Pi4 weekly build .. .but having issues getting lr-mess (and lr-mame as well) to compile.

    I did use your lr-vice scripts and they worked great. All new RA cores successfully configured and working.

    I'll keep working on my lr-mess issue and report back if I have success with the new lr-mess-xxx scripts.



  • @dmmarti if you use my repo(its on par with upstream, at least until this afternoon) there's a fix for lr-mess, it didn't compile to me either. btw, it takes 2-3 hours on a decent pc :)

    v.



  • Are your scripts available on a Pi 3?



  • @Zering sure just clone my repo and use it instead of the default RetroPie-Setup. rpi version shouldn't matter, its just that i'm using an rpi4, thats it.



  • @valerino ... I was successful now in getting lr-mess installed.

    I tested your lr-mess-arcadia.sh out. All good.

    Games launch and I'm able to play them. I'll test out your others as well when I have time.

    Good job!



  • @valerino good news regarding GSPlus emulation on Pi. After using your script, I installed and tested all major IIGS games and managed to get all of them the run; however I strongly recommend you make one change to your script:

    ROM Extensions should only be: .gsp .txt .GSP .TXT

    Should remove the .2mg extension completely. Each .gsp (or .txt) file will reference the .2mg images.

    My Rationale:

    1. .gsp and .txt are the default extensions for GSPlus configuration files.
    2. Each game needs its own unique configuration file to launch properly from ES.
    3. If you reference a writable .2mg file, and if GSPlus believes it's a configuration file, GSPlus will treat it as such and replace the contents with configuration information, effectively rendering the .2mg file useless.
    4. Use both upper/lower cases as described above, as typical with RetroPie standards. Will help people who don't mind (or don't notice) mixed case extensions.

    My Setup:

    1. Tweaked es_settings.cfg with the ROM Extensions I mentioned above. Nothing else needed to be changed.
    2. I'm only using "ROM01". It's WAY more compatible with games. ROM03 has issues. Optionally, this could be noted in the script help information.
    3. For each game, I put one (1) .gsp file in ~/RetroPie/roms/apple2gs
    4. Created a GS/OS hard drive Image (required for many games) and put it in ~/RetroPie/roms/apple2gs
    5. All of the .2mg files were extracted from ZIPs and placed in ~/RetroPie/roms/apple2gs/games (could be renamed as anything)
    6. For safety, I duplicated all .2mb files, put them in ~/RetroPie/roms/apple2gs/[backups] and made them read-only. This is kind of like keeping your original disks tucked away, and recalling them if you need them. About a dozen times, I was glad I did this. These games don't take a lot of space, so probably a best practice here
    7. Each .gsp in step 2 was manually configured to point to the various disk images in ./games and in some cases, the hard drive image
    8. In each .gsp, there are BRAM setting that automatically update when you change Apple IIGS control panel settings. This is VERY important for certain floppy configurations to work:

    The Three Major Floppy Configurations:

    1. Hard Drive bootable games: With the boot .2mg in slot S7D1 and optionally up to two more floppies in S5D1 and S5D2
    2. Floppy-drive boot required games: (the boot disk MUST be in S5D1. More disks can be added to S5D2)*
    3. GS/OS-required games (must boot hard disk in S7D1, and have non-bootable floppies in S5D1 & optionally S5D2

    Item 2 above required extra patience -- For each one of these, I had to enter the IIGS control panel and change the boot drive from default/scan to "5" in order to boot the virtual floppies. The cool thing as that you only have to do this once, as the IIGS BRAM data is stored in each .gsp file! This means each .gsp can act as it's own GS!

    Lastly, the joystick... My DualShock 4 wasn't responding. I learned that if you hit F4, go to "Joystick Configuration" and change Joystick Scale X and Joystick Scale Y to +10%, the joystick responds. Go figure. Unfortunately, there is no command-line argument to set Scale X and Y, so I had to edit all of the .gsp files to include this adjustment.

    As of now, 232 Apple IIGS games are up and running and properly configured!

    If desired, I can provide you with all of my .gsp files, since they're not ROMs -- rather they are the configuration files I spent the week working on. If somebody follows these instructions and uses these .gsp files, it will make the whole process A LOT easier. Otherwise, it's a lot of manual pain. :)



  • hi man! thanks for the feedback first for all! are you talking about the standalone gsplus or the lr-mess one? i'd prefer to continue work on retroarch emulators, thats why....
    can you try lr-mess-apple2gs too ?
    for sure i know that doesn't support .gsp, but you will have all the benefits from retroarch .....



  • That's solely for GSPlus. I'll play around with lr-mess next. :)



  • @roslof done, just committed your changes about extensions :) i haven't checked, but i think you know more than me about apple2gs :)

    btw ... i also added Dragon 32 :)



  • @valerino I see that! Awesome, man. Anxious to try a bunch of these out. After getting used to RetroArch, the stand-alone Coco/Dragon32 emulation left me wanting more. Will be a fun weekend.

    EDIT: The changes to the GSPlus script look good!



  • Just tried Arcadia.
    ...wow!
    Installed the script, copied over the roms, restarted ES. Boom! Worked!
    Very slick.



  • added Coleco Adam

    i really hope all this gets added to the retropie distribution ..... i'll add a bunch of other emulators (and try to fix bbcmicro), then i'll retry to submit a pull request :)



  • That would be nice.

    One thing about BBCMicro, the script is not adding ROM Extensions to es_systems. Looks like it's just a single space. I manually added .ssd .zip .SSD .ZIP.

    So now I can get to BBC BASIC, but Shift-F12 results in "File not found". I'll spend time trying to figure out why. Never worked with MESS before today.



  • @roslof again, its about the standalone or the lr-mess-bbcmicro ? i'm fixing it, since it doesnt work on me. running it via runcommand.sh leads to crash, instead it runs when running run_mess.sh from commandline.
    wait for a new version, i should have it shortly .... or if you happen to fix it, feel free to commit the code!!!!



  • Yes, lr-mess-bbcmicro. Knew you were having issues per the comments above, so was giving my input to help you out.
    Will commit fixes if I find them FWIW: Not crashing here. Just yielding a"File Not Found" after hitting Shift-F12.



  • @roslof try to run this

    /opt/retropie/configs/bbcmicro/run_mess.sh /opt/retropie/emulators/retroarch/bin/retroarch /opt/retropie/libretrocores/lr-mess/mess_libretro.so /opt/retropie/configs/bbcmicro/retroarch.cfg bbcb /home/pi/RetroPie/BIOS -flop1 /path/to/your/rom

    it should work. its an issue with runcommand.sh, i'm trying to override runcommand.sh for now....



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.