Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

error while loading shared libraries:



  • Hi I'm new to the pi world.... I'm raspberry pi was working perfect then I updated it and got this massage in Linux interface... it will not open emulationstation... the text reads... error while loading shared libraries: libvlc: cannot open shared file: no such file or directory... can anyone help me get past this so it opens emulationstation.



  • Provide this info please. I think I may know how to help here, but when you say "I updated it", I'm curious about what you did.

    Pi Model or other hardware: (B, B+, 2 B, 3, X86 PC etc..)
    Power Supply used: (If using a Pi)
    RetroPie Version Used (3.6, 3.8.1, 4.01 etc.. - do not write latest):
    Built From: (Pre made SD Image on RetroPie website, Berryboot, or on top of existing OS etc..)
    USB Devices connected:
    Controller used:
    Error messages received:
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: (Mention if you followed a guide)
    File: (File with issue - with FULL path)
    Emulator: (Name of emulator - if applicable)
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem:



  • I have a raspberry pi 3 model b... it is running version 4.0.1.. it is the raspberry pi power supplie... I did a binaries update and then a script update.. I am not sure if it's sd image or berryboot how can I check this... this is the method I used to update

    ... thanks for the help


  • administrators

    You should update the binary after updating retropie-setup



  • I did it in reverse does this matter ?


  • administrators

    @cocoeire yes. Order matters very much



  • Is there a work around or do I have to start again and rebuilt the pi ? I'm brand new to this thanks for the help


  • administrators

    @cocoeire just update the binary again if you have updated retropie-setup.



  • @BuZz thanks I'll try this... is there an ssh command to update them both ?



  • @BuZz that worked I'm back gaming thanks so much for the help.. šŸ‘šŸ‘šŸ‘



  • @buzz i have the same issue. How would i do this?


  • Global Moderator



  • @mediamogul thanks. Will try the command as i can't get into ES.

    I get this message after trying to update retropie:
    Retropie/supplementary/emulationstation/emulationstation: error while loading shared libraries: libbrcmEGL.so:cannot open shared object file no such file or directory


  • Global Moderator

    @bg223

    Browsing over your history, it looks like you're on borrowed time until you have to start over from scratch. Pre-built 3rd party images are not only illegal, but the people who set them up usually don't know or care what they're doing. It makes for a lot of extra work for us, so I hope you'll respect our policies and seek help from the people who sold you the setup in the future. You've been warned about this issue earlier and you're risking removal if you continue to ignore it. If you ever decide to start over with a clean image from this website, we're always more than happy to help you.



  • @mediamogul Listen , i don't appreciate the tone you're taking. I was looking for a retro games machine for a Christmas present for myself. I went halves with a family member. I looked thru many adverts on FB and online. I had no idea these small 'companies' or people selling retropie are doing it illegally.
    But also i would have no idea to put together a hdmi wifi box with a 360gb Harddrive. So please spare me the warnings like i'm some criminal. I just wanna play Chuckie Egg on the Sinclair. Or Road Rash on the Megadrive. If you can't help, fine. But i've seen others with nearly exactly the same problem and there is no high horse judgement going on. Just people trying to help.


  • Global Moderator

    @bg223 said in error while loading shared libraries::

    I was looking for a retro games machine for a Christmas present for myself.

    I hope it works out for you.



  • @bg223

    I understand your frustration, and the tone may be blunt from some of the members here, but we've spent a lot of time trying to help people only to find the people who build these machines have cocked something up so royally, the only way to fix it is to start from scratch.

    I would suggest that as a first port of call, go back to the person you purchased it from and ask them.

    Failing that, you will only get support from here without issue by reimaging the card to the stock image from here (which has no games installed).

    Sorry, but you've been burnt by an unscrupulous seller ā˜¹ļø



  • I love Xmas... More people being scammed by rip-off merchants, then expecting others to sort out their mess. I actually feel bad for this guy but rules is rules and zero tolerance to TP images is the correct way to go.
    Use the stock, official image and people here will break their necks to help you if they can. That's the best advice you'll ever get.



  • @jonnykesh so let me get this right....i get the image from here that has no games on it. Then what? I get the emulators and games myself yeah? So do you then pay for the emulators and games?
    Genuine question.



  • @simonster i haven't been scammed, this was my own doing. The machine works fine i just need to correct the directory it is looking for. I am 36 , i had a lot of the games that are on this retropie. You know, I paid for the games with my money when they originally came out. I'm not some thief. I just want to relive some of those games.

    If you don't want to help i get it. But don't act all high and mighty with me. 90% if not all of the people on this forum all downloaded the roms and games for nothing. What's so righteous about that?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.