Please do not post a support request without first reading and following the advice in

Powerblock + Low Voltage Lightning Bolt Icon

  • Sorry if something similar to this is already posted on here; I couldn't find it through doing a search.

    When I plug in via the PowerBlock, I notice the Raspberry Pi lightning bolt icon shows up on the screen. The bolt is an indicator, as far as I understand it, that appears when there's low voltage.

    I'm using a CanaKit 5v 2.5A power supply, so there should be an ample supply of power. Also worth noting, when I plug directly into the Pi, the bolt doesn't appear. It only appears when using the PowerBlock.

    It shows even when I do not plug in a peripheral such as a keyboard or controller. Also shutdown is painfully slow, taking 3 minutes and 16 seconds (yes I timed it) to shutdown. It also remains frozen in the emulator during this entire time, but I didn't notice this in particular happening until I did an apt-get update and apt-get upgrade today on my Pi.

    The only thing plugged into the PowerBlock is an LED and toggle switch. The PowerBlock is plugged into a breakout board.

    Any ideas? Thanks so much!

  • I've tried it directly on Pi headers, but really need to use it on a multiplexing board so I can free up some of the pins. The multiplexing board is this one:

    I've ordered a NorthPada® power cord which is rated at 5V 3A, so maybe that'll help? Either way, the problem with the 3+ minute shutdown probably won't be resolved. Wondering if anyone else is having an issue like me.

  • RE: lightning bolt. No issue with powerblock. Turns out a combination of my IDE ribbon and micro usb extender was the problem. I did troubleshoot before posting with multiple power supplies, and those were giving me the same results because of the other parts. Problem solved.

    However, shutdown is still slow. Still taking 3 minutes and 16 seconds. Yes, I've turned off "save metadata on exit." I also turned on "parse gameslists only" but neither of these have helped. Still looking into this issue.

  • Global Moderator

    Glad to hear that you solved the lighting bolt issue. The driver has been updated recently such that the delay of three minutes has been removed. You need to update your driver,

  • @petrockblog thank you for that! Worked like a charm. The PowerBlock is truly a necessity for me, and once I'm done with my pet project, I'll be sure to share.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.