Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Powerblock keeps rebooting



  • This is the first Pi build i did and the first time working with Linux based os environment.

    After adding the powerblock module and installing the driver script the first run went well after rebooting the pi shows no splashscreen (video) or ES Station.
    after 3 seconds it reboots and does the same the third boot it shows the splash after it reboots again.

    I restarted the powerblock installation 6 times from a stable backup i made of the sd card, i leave the first 3 lines out from the script because the complete update messes the xpad driver up some how.

    I even tried the powerblock installation from within retropie setup then the system runs fine but the shutdown script won't run apparently.

    Without te powerblock the system runs fine.

    Any body got ideas what went wrong or what i messed up?

    Thanks and regards Joost

    The powerbutton i used

    The script is used

    I added the 5v out on the powerblock for a cooling fan as mentiont here

    Pi Model : Pi3 Model B
    Media: Sandisk Ultra Microsd HC 32GB Class 10
    Power Supply used: Samsung EP-TA12EWE 2.0A
    RetroPie Version Used 4.02
    Retropie Setup script: 4.1.15
    Built From: Pre made SD Image on RetroPie website (retropie-4.0.2-rpi2_rpi3.img.gz)
    USB Devices connected: Microsoft Xbox360 Wireless controller reciever, Rii mini keyboard RT-MWK01
    Controller used: Xbox360 Wireless controller


  • Global Moderator

    It sounds as if the power switch is not correctly connected with the PowerBlock. In that case the RPi will shutdown right after boot, what would lead to the behaviour that you described above.



  • Today i solderd a new switch (thank god i orderd 2) after soldering i measured it with a multimeter and it works good.

    results are the same.

    i started on a small sd card with an clean Retropie image of the 4.02 and try installing the powerblock on that bij script.



  • So i tested with a clean 4.02 retropie image on a 16gb sd card and during the first controller mapping it started rebooting.

    Is it possible the powerblock unit is broken?


  • Global Moderator

    You can test if the PowerBlock reacts as expected to a pressed button by only connecting the two "switch" pins with each other (i.e., no real button is needed for that). That signals the PowerBlock to turn on. As soon as that connection is interrupted, the PowerBlock emits a shutdown signal to the RPi, which in turn will initiate a shutdown.



  • I tested Withe a clean new build of 4.02 without powerblock and it ran like clockwork, then i tested the same build with the powerblock and ik bridge the switch pins so they would stay on it booted but as soon as es station is active it reboots.

    The second time i tried booting it it would not boot at all.

    Today i tried the clean 4.02 without powerblock it booted the right way, then i thried with the powerblock and still it would not boot no lights nothing.

    I think thid powerblock has lost the fight somehow.


  • Global Moderator

    Can you send me your order ID via email please? I will take care for a replacement then.



  • I Send the mail by the contact form on the petrockblog site


  • Global Moderator

    Got it. You will get a mail soon!



  • I got the new powerblock in today, will try it as soon as i have time



  • Well finaly i got to putting om my new powerblock after putting in the script code it seemd like it went the same way as the previous version with the rebooting and all.

    I removed the powerblock went in to the retropie setup and updated the installation script, then went to the drivers and installed the powerblock from there.

    After a reboot it works like a charm now.

    Thanks Florian

    Retropie rocks !!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.