Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Apple IIgs emulation



  • I know you have linapple incorporated into Retropie for emulation of the Apple II range, but what about the Apple IIgs?

    I think it's emulation is part of the experimental port of lr-mess2016 but I found a better experience (on Windows at least) from GSplus.

    http://apple2.gs/plus/

    The page says that it's in alpha quality but, like I said, i found it to work very well.

    Its git project is here.

    https://github.com/digarok/gsplus



  • @GeoNeilUK I've mamnged to compile it on the Pi, here's the bother I'm having...

    Compiled it by following the instructions here...

    https://github.com/digarok/gsplus/blob/master/doc/Developer-QuickStart-Linux.txt

    But changing out...

    ln -s vars_x86linux_x11 vars

    for...

    ln -s vars_rpilinux_fb vars

    ...and editing vars_rpilinux_fb to change the line...

    NAME=gsportfb

    ...to read...

    NAME=gsplusfb

    and then compiling

    There is a vars_pi file which I'm not sure refers to (I assume it's the Raspberry Pi)

    But anyway, some problems...

    There doesn't appear to be any sound

    There's no way to quit the emulator without killing the gsplusfb task.

    After killing the task, you're left with a screen at the same resolution as the Apple IIGS itself (extremely low)

    Also, I haven't tried launching it from emulationstation yet, just the desktop.

    Looks promising but not there yet and I have no idea what I'm doing.



  • Tried and failed to get it to launch from emulationstation. Launching it from command line is a bit worse, the app takes up the entire screen, meaning you have to disconnect and reconnect the power to get your system back.

    I even tried SSHing in and killing the gsplusfb task, but that just leaves a frozen Apple iigs display and no apparent way to get the system back.

    This is a bit of a head scratcher. Not sure where to go from here.



  • @geoneiluk OK seems nobody else has bothered with this...

    I've tried creating a custom vars file and called it vars_rpilinux_sdl2

    NAME = gsplus
    PERL = perl
    CC = gcc
    LD = g++

    OBJECTS = $(OBJECTS1) $(TFEOBJ) $(ATOBJ) $(PCAPOBJ) sdl2snd_driver.o fbdriver.o

    C Compiler Options

    CCOPTS = -O2 -Wall -fomit-frame-pointer -std=gnu99 -march=armv6 -DHAVE_SDL -DHAVE_TFE -DHAVE_ATBRIDGE -DTOGGLE_STATUS -I/usr/include/SDL2 -I/usr/include/freetype2

    C++ Compiler Options

    CPPOPTS = -O2 -DHAVE_TFE -DHAVE_SDL -DTOGGLE_STATUS -DHAVE_ATBRIDGE -I/usr/include/freetype2 -I/usr/include/SDL2

    EXTRA_LIBS = -lfreetype -lSDL2 -ldl -lm -lstdc++
    OPTS = -DGSPLUS_LITTLE_ENDIAN
    SUFFIX =
    LDFLAGS =
    LDOPTS = -I.
    EXTRA_SPECIALS =

    It's only slightly better, ghosts of the desktop keep coming through when I launch from the desktop.

    Sounds works... but only when I launch from the console ...then I launch a game, gsplus crashes and I'm left with a black screen until I reboot.



  • Apple II GS works really well on the apple2pi... on my pi zero it works great. theres a customer build of gsport, perhaps the guys behind it will pass on the source or builds?

    https://github.com/dschmenk/apple2pi

    itd, be great to have gs on retropie!



  • @iainjh Reading the readme on the apple2pi it sounds more like a way to interface with the Apple II components from an Apple II than an emulator. Is this what they used on the Think Different Challenge that I saw on 8bitGuy?
    Is the emulator you are referring to called GSport? https://david-schmidt.github.io/gsport/



  • sorry for such late reply, i didnt get a notification...anyway

    1. yes it looked to be the same thing they used

    2. gsport, yes



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.