Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

NES30 8bitdo HELP



  • Pi Model: pi3
    RetroPie Version Used: unknown
    Built From: SD Image
    USB Devices connected: nothing
    Controller used: ps3
    Error messages received: N/A
    Guide used: https://retropie.org.uk/docs/8Bitdo-Controller/
    File: N/A
    Emulator: SNES
    Attachment of config files:
    How to replicate the problem: Tried with 2 BT controller

    So basically I can pair my NES30 controller no problem it works and buttons appear to work in emulator station but when I enter into the SNES emulator it appears some buttons may not be mapped correctly???As it appears some buttons work I just cant get past the start menu in all the games I've tried and I cannot exit back to the ES as the start/select are unresponsive. Note: I updated my controllers to 3.0 firmware and update the RetroPie to:
    commit c522c722b6753b1908d7f5fa00b4bc1e105e514a
    Author: Jools Wills buzz@exotica.org.uk
    Date: Wed May 3 20:18:10 2017 +0100

    Also, not sure what i need to do for different emulator but start does work on NES games and select but I cannot start/select out of the game nor does button A work.

    I'm going to try the setup guide one more time to see if I missed something but I am pretty stuck.



  • @bsalazar23 here is my suggestion: toggle the 8bitdo hack and configure your joystick again in emulationstation.



  • @meleu Its currently set to off...but Ill try again.



  • @bsalazar23 when I say "toggle" I mean "switch from one state to another". ;-)



  • HAHA I got ya...okay trying now. I appreciate the guidance. The only thing I can tell I am doing differently from the guide or youtube is that my controllers is NES30 not a SNES30 but it has the required 12 buttons.



  • No Bueno...I am on 8bitdo firmware 3.0 too



  • @bsalazar23 please, paste the content of those files in ghostbin.com (or some similar service):

    • /opt/retropie/configs/all/retroarch.cfg
    • /opt/retropie/configs/nes/retroarch.cfg
    • /opt/retropie/configs/snes/retroarch.cfg
    • /opt/retropie/configs/all/retroarch-joypads/8Bitdo NES30 GamePad.cfg (or a name similar to that).


  • /opt/retropie/configs/all/retroarch.cfg
    https://ghostbin.com/paste/z4rh9
    /opt/retropie/configs/nes/retroarch.cfg
    https://ghostbin.com/paste/qeezy
    /opt/retropie/configs/snes/retroarch.cfg
    https://ghostbin.com/paste/z4emr
    /opt/retropie/configs/all/retroarch-joypads/8Bitdo NES30 GamePad.cfg
    https://ghostbin.com/paste/3xw6x



  • @meleu thanks again for the help...I truly appreciate it. I would be lost...I am lost lol.



  • Okay so just to update I edited my SNES.conf file and mapped the buttons to the controller....which worked....which I think is what you were guiding me too. The only one I cant seem to figure out is exit emulator currently its set to value of 9....not sure how to figure out what select + start equate to on the NES30 remote but getting close. THANK YOU SO MUCH for the help



  • @bsalazar23 your retroarch.cfg for NES and SNES (and maybe other systems too) are cursed by the "config_save_on_exit setted to true" curse. And this is the main reason of all your confusion.

    Look if you have, retroarch.cfg.rp-dist files. Example for NES: /opt/retropie/configs/nes/retroarch.cfg.rp-dist.

    The "uncursed" NES config file looks like this:

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = "/opt/retropie/configs/nes/"
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    

    If you have those files on /opt/retropie/configs/SYSTEM_NAME/ directories. I suggest you to replace your current retroarch.cfg with the content of the respective retroarch.cfg.rp-dist file.

    If you wanna know why enabling config_save_on_exit on RetroPie is a bad practice, take a look at this post.



  • @meleu so....everything working it appears. I edited my SNES file and I missed the hot_key stuff so now I can exit my Emulators....thank you for the help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.