Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Xbox 360 Connectivity Issue



  • Pi Model or other hardware: Pi Zero
    Power Supply used: 5V 3A psu
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2.
    Built From: Pre built image. https://retropie.org.uk/download/.
    USB Devices connected: USB Snes, Zettaguard xbox receiver, wifi
    Controller used: Microsoft Official Xbox 360 Controller
    Error messages received: N/A
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: N/A
    File: N/A
    Emulator: N/A
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem: I have tried connecting the xbox controller numerous times. A couple times it has connected and worked great. If I restart the system it does not work. I have tried uninstalling xpad and reinstalling it, updating it, even tried the xboxdvr to no avail. It is sporadic.



  • To add to this I was able to get it connected again. It worked and I tested a couple games. I restarted the Pi and it would not work. If I shut down the pi and turn it back on, then turn the controller back on it connects. If I go to config to setup Joypad order it only shows '4' xbox controllers even though only 1 is connected. I shut down a couple more times like normal and booted up and controller connected. Now I shut down and boot the system back up and controller does not connect. Just blinks. When it does connect it will show player 1.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.