Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Firstly, sorry if this question was answered before, I've really looked into it for two days before going ahead and making this topic.

    I have a Pi3 running Retropie 4.2 with yesterday's (10 june, 2017) updates, and I'm trying to install overlays using rp-video-manager in mame-libretro.
    While the overlay work and show as expected, showing the each game's .cfg file are indeed loaded when I open the game, I can't get the viewport options to work. I've tried to edit it manually, tried to grab other people's config files from the forum, even tried to set in mame itself by using config editor from retropie and nothing seems to work.
    One thing actually works, if I set those values from retroarch config menu (select+x) it will look as I want, but it does not save this configuration, even if I set save on exit or try to write over retroarch.cfg (that actually fails).

    I know Linux, so messing with config files is not new to me, but this time I really don't know what to do. I had this working on retropie 4.1, but in 4.2... well I just can't. So, if anyone can help me out, or give me a hint/clue, I'd appreciate.


  • OK, to answer my own question, I found the problem soon after posting here (Murphy law in action).
    For some reason I had a file ~/.config/retroarch/config/MAME 2003/MAME 2003.cfg that was overlapping the configs. Removed it and started to work.
    I don't know WHAT created this file, but I will let the infromation here in case someone has the same problem.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.