Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Roms won´t start - strange problem



  • Hi everyone,

    i am getting crazy. Meanwhile i have spend several hours investigating on my problem.
    Now i decided to access this help forum.

    I have a pi3 and the latest emulationstation installation.

    When i ssh into my pi and start the emulationstation via bash everything is fine.
    Everything is displayed on my tv as it is connected via hdmi.
    Only the "text" messages are displayed in the ssh window.

    So when i start emulationstation on pi reboot eg "autostart" emulationstation is also displayed on my tv but the roms doesnt start.
    The screen goes black and after a second or two i am back in the romlist.
    I am missing the "text" display on the screen.

    When i start again via ssh it all works normal.

    Whats wrong here ?
    Any suggestions ?

    I would really like to use the autostart. It seems somehow the "text" display port is not bound to the tv ?



  • What emulators? Any bios files? More info



  • Its on every emulator the same..

    SSH works

    direct TV (via autostart) not


  • Global Moderator

    @Dlay

    Launch a game, then let it fail and post the contents of /dev/shm/runcommand.log.



  • In SSH case the file is filled normal.

    In autostart case the file is emty


  • Global Moderator

    @Dlay said in Roms won´t start - strange problem:

    I am missing the "text" display on the screen.

    Exactly what text are you expecting to see? Please, give an example of a successful launch command that you're using from SSH.


  • Global Moderator

    @Dlay

    Also, go ahead and fill out the required information detailed at https://retropie.org.uk/forum/topic/3/read-this-first.



  • I am expecting to see the screen where you can configure the emulator with this rom.

    What also doesnt work is the Retropie-Setup screen.
    Normally this is also a text based screen.

    But i cannot see it on the tv.

    Then also the screen goes black and the retropie menu appears again.
    So everything in graphics mode works well but the fallback to the textscreen not.

    Please forgive me when i dont post all the info.
    The pi works perfect. Also emulationstation when starting via SSH.

    So there is something going wrong which the runcommand.log doesnt cover.
    Therefore i think it is strange to post an empty file.


  • Global Moderator

    @Dlay

    Please forgive me when i dont post all the info.

    Posting that information helps save a lot of time and guesswork on our end. You never know what might be important. It may be a pain and it might even end up being irrelevant, but it's the process you agreed to when you signed up here.

    Also, has your RetroPie setup ever worked? Is it a new install? What method did you use for installation?



  • I understand what you mean.

    The setup works total normal via ssh. I told already a few times. I can play all games, with sound, xbox pad, everything fine.
    The installation is about 2 weeks old via apt-get install retropie.





  • also i think that the problem startet when i did an "Update all installed packages" via the setup-script.

    Actual version is 4.27 here



  • Meanwhile i found an error message in some other place:

    /opt/retropie/supplementary/runcommand/runcommand.sh: Zeile 965: /dev/tty: Kein passendes Gerät bzw. keine passende Adresse gefunden
    Unable to open /dev/tty

    It is like i thought before, i will investigate further


  • Global Moderator

    @Dlay

    Meanwhile i found an error message in some other place

    What other place would that be? I can only guess why you're being so vague on the details, but you should be able to solve this whole mess by downloading a fresh premade image , then install it using these instructions. From there, you will then be able to update all packages without issue.



  • Isnt there a way to avoid the text screen after starting a rom ?

    Thats the only problem i have.


  • Global Moderator

    @Dlay

    You can disable the runcommad menu, but I have a feeling that won't solve anything. What OS have you installed RetroPie onto?



  • Simply, raspbian os

    I dont like the idea of a fresh install. Also my homeautomation server and an instance of omv is runnig on it. And there has gotten many hours of configuration into these..



  • Ok, so a few things:

    The runcommand window and anything terminal based will be launched on the "console" tied to the main process that launches emulationstation.

    If it's launched from SSH, you'll see them in your SSH window.
    If it's launched "normally" from the raspbian boot, it would show on the TV.

    The message you're getting on runcommand seems to suggest the same: it can't find or use the console for whatever it's trying to (that's /dev/tty).

    I don't know enough about autostart and such. If you're confident that this is a very recent change, it'd probably warrant a bit more investigation, but last time it was changed it was 3 months ago, so if you installed this 2 weeks ago, then no changes would have been made since.

    That particular line (965) has been there for 7 months as well.

    If you're keen on troubleshooting, you may want to try to revert to previous versions of runcommand.sh and see if it helps - if you manage to narrow down a version where it runs and one where it doesn't, I'm hopeful it can be fixed.

    That's the best we can offer at this stage.

    If you want to clarify a bit more what you mean by launching with autostart, that may help. Are you running X? Is this launched on boot?


  • Global Moderator

    A summary so far:

    Pi Model or other hardware: Pi3
    RetroPie Version Used: 4.27
    Built From: On top of existing undisclosed version of Raspbian
    Error messages received:
    Log found in /dev/shm/runcommand.log (if relevant): Log found in undisclosed location:

    /opt/retropie/supplementary/runcommand/runcommand.sh: Zeile 965: /dev/tty: Kein passendes Gerät bzw. keine passende Adresse gefunden
    Unable to open /dev/tty
    

    Guide used: https://github.com/RetroPie/RetroPie-Setup/wiki/Manual-Installation
    How to replicate the problem: Launching a file locally fails, resulting in a return to Emulation Station.



  • Thank you for your effort in this.
    I should have said this earlier :-(

    There is no X environment running on the pi.

    I mean when i enable the option that ES/RP starts directly at boot time.
    Then there are no tty screens displayed.

    As you have written correctly, in ssh all is fine.

    Even if i disable the runcommand options its still the same.
    I am near to give up..



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.