Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Power block and low voltage indicator



  • Re: Powerblock + Low Voltage Lightning Bolt Icon

    Im having a similar issue to Wanderingme (referenced above). I have an RPi3, and powerblock.

    I'm getting the yellow lightning bolt all the time. My controllers (PS3) aree frequently dropping communication. The whole setup is not working smoothly.

    I started with the most recent retropie image yesterday. I did apt-get update and upgrade. I installed powerblock software. The powerblock does what it should...the pi boots from the switch, and shuts down (not taking 3 minutes...it's quick) when I flip the switch.

    Retropie is misbehaving and constantly dropping communication with the controllers. Even the keyboard. The yellow lightning bolt is showing constantly.

    I noticed that wanderingme removed the female header from the powerblock, and connected it to the pi via a ribbon cable. I have done a similar thing. I soldered male headers onto the powerblock, and connected to the pi via a ribbon cable. My setup is inside a commodore64.

    Question for petrockblog.....sir....is it likely that the ribbon cable is the problem? It seems unlikely to me. Can I check with my multimeter? If so can you advise which pins I should measure at the pi end and what I should be looking for?

    The fan is connected to the supplementary 5v pins on the powerblock. Wondering if this was the issue I disconnected it but it made no difference.

    My 2.5A power supply is connected directly to the powerblock - there's no extension there. The extension cables you see are all just the USBs.

    I'd really appreciate any advice you can give. I have another power block on its way to me for a new version I'm making for a friend.

    0_1498089087757_powerblock.jpg



  • @petrockblog - can you help?

    Tonight I plan to try to debug things. First I'll start with a fresh SD card image. I'll power the pi from it's USB port. See if my controllers are behaving, and check that Im not getting the undervoltage icon. If I am - then we know it has nothing to do with the poweblock configuration and maybe there's something wrong with my PI.

    If all good, I'll install the powerblock software/hardware and see where I get to.

    I know you're all more likely to be able to help if I provide more detailed information. I was kindof hoping that undervoltage when running retropie and using powerblock....was a known issue with workarounds I could try, or if you'd know right off the bat that I had gone about things incorrectly.



  • @Ppppigeon off topic. Sincei dont see you dont have a keyrah adapter like i used on the c64, how are you using your keyboard?



  • @edmaul69

    not using the keyboard - I didnt think it was worth the trouble. Really the C64 here is just a case for the PI. I had a C64 when I was a kid and played a lot of games on it...Im happy enough using it as a box and playing SNES games etc. Have installed VICE and plenty of C64 ROMS but havent figured out how to get it to work yet.


  • Global Moderator

    If you see the lightning bolt, it is an issue with the power supply. Here are my thoughts for solving that issue:

    • Try to introduce one component after another: First connect your power supply and only your power supply to the PowerBlock. Detach the fan and all USB devices. If the lighting bolt still shows up, you need to get another power supply. We made very good experiences with the official power supply. I do not have any experiences with integrated power supplies, but you should try another one then. Also, if the cables between the power supply pins and the power supply itself are thin, you could try and replace these with thicker wires.
    • The ribbon cable could be the reason for the issue as well. To rule that out you could either directly attach the PowerBlock to the RPi. If you have already replaces the female header you could use thicker wires instead of the ribbon cable. You might also want to use the dedicated pin outs as shown here: alt text

    The uses pins are:

    5V IN, +,-: supply voltage
    S1: pin 12
    S2: pin 11
    5V OUT +: pin 2 or pin 4
    5V OUT -: pin 6 or pin 9
    
    • If the above step works you could connect the fan and see if that changes anything.

    I bet it is because of a too weak power supply or low-quality/too thin wires.



  • @Ppppigeon the standalone vice, when you put both the keyrah keyboard adapter and the vice emulator in the correct mode, the keyboard is so perfect. I would definitely recommend a keyrah v2 for this.



  • @petrockblog You are right, ribbon cables usually are thin wires (higher resistance) and I do not recommend using it for power connections, especially when you already have a weak power supply. And any of the above you mentioned could be a contributing factor.



  • Thank you all for your advice...and thanks so much for taking the time @petrockblog . I will try all your suggestions.

    The power supply is a 2.5A one which I got in an RPI kit. However.....it wasnt an official kit so there's a good chance it's not good enough.

    If I had to guess now - I'd say my ribbon cable being used for power between the powerblock and the pi is going to be the problem. I have another one on order and I expect it'll arrive quite soon so I can try that one using it's female headers.

    At the weekend I got as far as eliminating the pi itself, by powering it directly from the power supply (not using the power block). No lightning bolt. So I'm getting closer.

    Thanks again - I'll report back when I get this sorted.



  • My new powerblock arrived (for a ZX Spectrum project). I was able to start my test by simply replacing with the new powerblock, connecting it using the headers the way it's shipped. Everything worked perfectly - there's no lightning bolt symbol.

    So - you were right - the wires I'm using to connect my headers-removed powerblock to the RPi are presumably too thin. I'll have to find something better and connect it as you describe above.

    Will let you know when it's solved.

    thanks again



  • Looking at the picture you posted....why do you have the RPi in a case with the fan? Is the Pi overheating or is that just precautionary? Unless you are overclocking the Pi, there is really no need for the fan. Enclosing the Pi in a case prevents air circulation. The ZX case you're using has plenty of ventilation. I suggest remove the Pi from the case and loose the fan. Put the Powerblock right on the RPi per instruction and you will have a better connection. You will have a more stable setup than using a ribbon cable. If the fan is really needed put it on the ZX case and blow the hot air out. Do not blow air into the case.



  • I was concerned that the pi would get hot encased int he computer box. The powerblock provides for a fan, so I thought I'd try it. Mounting it in the case with the FAN attached seemed a good solution. I can take the lid off the case and leave out the fan - may as well since Im having power related issues and no overheating issues at this stage.

    I relocated the power block only because I wanted the micro usb power input socket at the back of the C64 case. I could have used a male to female micro USB but did it this way instead - not realising I would have an issue with the resistance of the wires I used to dliver power between powerblock and pi.

    I'll either use better wires, or try to find a micro USB male to female extension.


  • Global Moderator

    Glad that things are working for you now :-)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.