Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Emulationstation crashes after RetroPie boots up - Permission denied



  • Can you type?



  • I can't get to a command line during boot by pressing f4 , it just ignores it and eventually tries to boot emulationstation and bombs with that error.

    Is there any way to fix this? It seems a bit extreme to have to start all over again after only having it working for about 2 days.

    If not I guess its bound for the bin :(



  • Good luck getting anyone here to help you.



  • @jamesk you can try to ssh into the Pi and execute whatever commands you need to.



  • @pjft said in Emulationstation crashes after RetroPie boots up - Permission denied:

    @jamesk you can try to ssh into the Pi and execute whatever commands you need to.

    If you're able to do this, please let me know.



  • This issue still exists. Copying over a rom directory with broken permissions (via usb) breaks the permissions on the retropie and crashes EmulationStation on startup.

    • F4 pressed throughout the boot process and initial ES splashscreen don't work
    • No keyboard input works after ES crashes with the boost filesystem permission error and I get dropped to the terminal
    • Attaching keyboard/gamepad post-ES crash doesn't work either

    Because it is a mostly-fresh install, SSH is disabled and SMB does not have permission to delete the affected file.

    My only guess is to try and mount the sd card in Virtualbox or another RetroPie.



  • I'm having the same problem and have yet to find a fix that works. F4 doesn't do anything. The only way around I've found is to completely re-flash the SD and start from scratch without the files that caused the error


  • Global Moderator

    @chachenstein You can use SSH to reset start the RetroPie setup and reset the ROM dirs permissions. SSH is not enabled by default, but can be easily enabled (https://github.com/RetroPie/RetroPie-Setup/wiki/ssh). There's no reason to re-flash your image.



  • @mitu But the keyboard is disabled when it crashes, so you can't type the commands to even open raspi-config to be able to enable SSH.

    What I had to do when it happened to me was burn a Linux Mint installation image to a DVD, boot the Linux Mint on my computer from the DVD (in Live CD mode, it isn't necessary to install it), put the card in the computer's card reader, and use a terminal to access the SD card, find the affected folders and files and sudo remove them.

    It probably would work the same with Linux in a USB stick. Maybe even with it installed in a Virtual Machine on Windows, but I'm not sure.

    Either way, its not something trivial, so if you have a working backup, or if you have the roms somewhere else and it is a new installation of retropie that you haven't configured and changed much, re-flashing might be the more practical option.


  • Global Moderator

    @isrnick said in Emulationstation crashes after RetroPie boots up - Permission denied:

    @mitu But the keyboard is disabled when it crashes, so you can't type the commands to even open raspi-config to be able to enable SSH.

    The simplest method to enable SSH is to drop a file on the /boot partition, which if FAT32 and can be done from a PC. It's explained in the link to wiki:

    From a system with an SD-card reader, access the /boot/ directory and create an empty file called ssh

    You don't need a keyboard, just a network connection. Once logged in, you can invoke the RetroPie-Setup and then reset your ROM folder permissions (https://github.com/RetroPie/RetroPie-Setup/wiki/FAQ#reset-ownershippermissions-of-homepiretropie-roms).

    I'm thinking that another way is to press Ctrl+C immediatelly after boot, when you see the ES splash (from a keyboard) so ES start is interrupted. I don't have a keyboard attached to the PI to test it.



  • @isrnick said in Emulationstation crashes after RetroPie boots up - Permission denied:

    @mitu But the keyboard is disabled when it crashes, so you can't type the commands to even open raspi-config to be able to enable SSH.

    Sometimes, I can free the keyboard by pressing Alt+PrtScr/SysRq+R simultaneously. It's a Linux Magic SysRq key combination that switches the keyboard from raw mode, which graphical programs tend to use, to XLATE mode. May be worth a try.

    Note that on some keyboards, Laptops etc. the key combination is slightly different. See the link above for the variations.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.