Please do not post a support request without first reading and following the advice in

8Bitdo SNES30 4.0 Firmware - No Longer Working With Retropie?

  • Hi! I'm using a Pi 3b with Retropie 4.2.12 and an 8bitdo SNES30 pad. I have normally been able to pair the pad with Start+R, but once I update my pad the the 4.0 firmware, Retropie will no longer find it when looking for it as a bluetooth device. I've also tried removing it and adding again, but to no avail. Have any of you all had this problem with this pad after the firmware update? Thank you all so much!

  • @saikyo78 mine stopped connecting when i updated it and used it on my switch. But all i had to do was delete it from the Bluetooth list and connect it again. But i think the button combo might have changed. Try just start when booting the controller up for searching, or start + some other button.

  • Thank you so much! I have tried just start, and other button combinations as well to no avail. Oddly enough, when I switch back to 3.00, it syncs just fine. I wonder if right now, we will have to switch for 4.00 for the Switch, and 3.00 for Retropie?

  • I use the FC30 player 1&2 set both updated to firmware 4.0.
    No problems here. During the pairing try to push buttons on the controller that might help to find it.
    It took me also 2-3 tries before he could find the controllers.

  • @saikyo78 you shouldn't have to, i didnt downgrade my controller after playing on the Switch, and im currently using it on Retropie. (Maybe 8bitdo has updated their manual / faq?)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.