Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

SDL Build Error with on Linux Mint 18.2 Sonya



  • Basically, whenever I try to install RetroPie on Linux Mint 18.2 Sonya, it returns an error about not being able to build SDL2 (Could not sucessfully build SDL2 /home/tunnel/RetroPie-Setup/tmp/build/sdl2/libsdl2-dev_2.0.5+5_amd64.deb not found). I am assuming RetroPie is attempting to build 2.0.5 when the package libsdl2-dev installed from apt is at version 2.0.4+dfsg1-2ubuntu2. Is there a way to fix this build error? Or possibly a way to install a newer version of libsdl2-deb from apt?

    The full log: https://hastebin.com/iqarojigad



  • I edited
    scriptmodules/helpers.sh: local own_sdl2=1
    to
    scriptmodules/helpers.sh: local own_sdl2=0

    This just uses the default sdl2 installed on the system. Seems to work ok



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.