Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

exit emulator was working with 2 button (start + select) now not



  • Pi Model or other hardware: 3
    Power Supply used: 5V,2A
    RetroPie Version Used: 4.2
    Built From: Pre made SD Image on RetroPie website, https://github.com/RetroPie/RetroPie-Setup/releases/download/4.2/retropie-4.2-rpi2_rpi3.img.gz
    USB Devices connected: keyboard
    Controller used:Xbox 360 controller
    Error messages received: none
    Log found in /dev/shm/runcommand.log (if relevant): don't think so
    Guide used: (Mention if you followed a guide): no guide
    File: (File with issue - with FULL path): /opt/retropie/configs/all/retroarch.cfg
    Emulator: (Name of emulator - if applicable):mame4all
    Attachment of config files: Don't think you need full config file, but can provide if needed.

    I have a vanilla install of 4.2 from the image on the website. It was working great. select + start would exit games no problem. Then i went into one of my mame roms and hit 'tab' then when setting the 'add coin' i accidentially hit the start button. I picked a different button for 'add coin' but now select+start doesn't quit out of mame4all games. select+start quits out of all other emulators (n64, nes, mame-libretro, etc..) but not mame-mame4all.

    I have searched this form and others and found two threads which seem to address the issue, but just don't seem to work for me.

    I have run jstest on my controller and it says my select button is button 8 and my start button is button 9. I have done nothing else to the default /opt/retropie/configs/all/retroarch.cfg file other than I have set the following two flags in the /opt/retroarch/configs/all/retroarch.cfg file:

    input_exit_emulator_btn = 9
    input_enable_hotkey_btn = 8
    

    in the two threads linked above and throughout other places on the interwebs, i have seen multiple references to start+stop as the default behavior. Perhaps somehow the default settings is somewhere other than /opt/retropie/configs/all/retroarch.cfg

    I also tried to somehow set 'button bindings' within in the 'tab' menu of mame. Sadly there seems to be no option for 'exit emulator' within the tab menu.

    I have tried to follow the rules of first post, if you need more information, please don't hesitate to ask. I really appreciate the forum's help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.