Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PSX Bios installed but not recognized



  • Hi there!
    I know there are many Threads about the PSX Bios but none of them solved my problem. Perhaps I don't have any problems but I had to ask.

    I ran Retropie an a Pi3b with an external USB drive. I configured the USB drive as explained in the docs (format with FAT32, created a directory named retropie-mount, etc) that works fine for me. Every folder is created inside the retropie-mount folder and I can see my roms and start them.

    I installed three PSX BIOS Files in the BIOS folder. (scph5500.bin, scph5501.bin scph5502.bin) The md5 checksum is correct for these files. Also, I installed the retropie-manager package and when I look at the bios page it seems that the BIOS files are correct (the three entries are decorated and followed with a checkbox).
    But when I start a ps1 game i get the message that no BIOS file was found and that I have to install one for better performance. But the games start and I can play them.
    So my question is, is there any issue with my installation?
    Thanks for any help!

    r3d007



  • @r3d007 try putting them all in caps including the .bin. Also is the thumb drive only used to transfer roms or do they boot off of the thumbdrive. If it is used to transfer to the sd card then it is known to be an issue. You would need a program like winscp to transfer the bios files.



  • @edmaul69
    When I put the BIOS files in caps the Retropie Manager doesn't recognize the BIOS files anymore. In lower they are shown as installed.
    The Pi boots from SD Card but all my roms and BIOS files are on my USB drive. All games are still on my USB drive. I don't copy anything to the SD Card.
    There isn't any entry in the fstab but the mount command says that the USB Drive is mounted to /media/usb0 and /home/pi/RetroPie. I configured the USB drive as explained here (Automatic Mount (Easiest Method))



  • @r3d007 can you manually put the bios' on by plugging the thumbdrive into your pc or use winscp instead of retropie manager. I would make them caps and put them in the bios location on both the sd card and the usb drive.



  • @edmaul69
    i copied the BIOS files via samba, ssh and by plugging the thumbdrive and the sd card to my computer and copied them. still the same result. same when i write them in caps.
    now the bios files are on the sd card and on the usb drive but the usb drive is mounted to /home/pi/retropie so everything i copy to this directory isn't visible when the usb drive is plugged in (then there is everthing on the usb drive visible)
    i recognized that non of my Sega CD's work, too. think it is the same issue that retropie can't find the bios files.



  • @r3d007 do you have the correct sega cd bios for the sega cd emulator you are using? They are listed here. Caps and lowercase and correct bios per emulator have to match whats here



  • @edmaul69
    now i've tried to copy the bios files and a game just to the sd card without using my thumbdrive. same result.

    but the md5sum of my bios files match the md5sum in the wiki. now i'm more confused than before.



  • @r3d007 try giving 0777 permissions to the files. See if that helps.



  • @edmaul69
    nope doesn't changed anything.

    any other ideas?



  • @r3d007 stick them in their systems game roms folders



  • @r3d007 and try this with both systems. Dont assume because it didnt work in one system it wont work in the other.



  • the only bios file you should need for psx is SCPH1001.BIN
    delete the ones you put in, download and add this one instead, restart the pi and this should work?



  • @w44dde you need to remove the link. Naming and linking rom sites is against the forum rules.



  • @edmaul69 my bad!



  • @edmaul69
    Thanks now it works fine. I put the BIOS files into the rom folder and SegaCD games are running and no error message from PSX.
    Thanks for your help.



  • @r3d007 no problem. Glad i could help.



  • @r3d007so i decidedto solve the mystery of why you had to put the bios' in the roms folder. if the retroarch.cfg in /opt/retropie/configs/all/ does not have the line:

    system_directory = "/home/pi/RetroPie/BIOS"
    

    or it is #hashtagged out, or you edited the retroarch.cfg for those systems either manually or through the retroarch gui, that made major config changes then you need to put them in the roms folder. to fix this open up /opt/retropie/configs/all/retroarch.cfg and see if that system directory line is in there. if it is #hashtagged out, remove the hashtag and save.if it is not in there, then add it. if it is correct open up the retroarch.cfg in the individual systems config folders and find the issue and delete or correct it. the rgui can mess things up when you are using it, hence why i never use it to configure anything other than core-options.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.