Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Amiga] Amiberry + WHDLoad = Holy Grail - Amiberry's official thread


  • @George-Spiggott no problem. Do you know your exact Pi config? I mean do you rely on a default Retropie install and update system packages from time to time? Or do you have a more fine-tuned setup eg. you've enabled the KMS driver for instance? What kernel version do you have? Also when you'll be able to, please check again your amiberry.conf file again to see if the 2.05 KS has been added (I still recommend you to delete the 2 other KS).

    I really can't reproduce your issue here on my Pi4 (no overclock, no WIP or in-development driver or kernel, just the default).


  • @nemo93 Yes I updated to the new kernel and I am running the KMS driver with the legacy sound driver. I'll check the exact version later tonight. I will check amiberry.conf as soon as I am able.

    Thanks for the continued help.


  • Hello together,

    as I am putting together a new RetroPie unit one short question: as the 4.6 image comes with Amiberry 3.1.3 - how do I update to the latest 3.2 correctly?

    Thanks for pinpointing me into the right direction.

    cu,
    agerhard


  • @agerhard Hi, I’m not sure the binaries have updated yet, update from source in the RetroPie setup menu, Amiberry is located under optional packages, and it will update to 3.2.


  • Hello Stuffu, thanks for the info. Installed Amiberry from binary first - an option to "update" from source does not seem to be available. Do you refer to "Install from source" maybe?

    cu,
    agerhard


  • @agerhard yup, that’s it!


  • Hi everybody, does anyone feel that games run a little faster then normal?
    I'm loading LHA files using lastest version of Retropie and Amiberry built from source on a Rpi 3B+.

    For example, in Kick Off when players enter the stadium there was a slowdown in original hardware and FS-UAE but not in Amiberry and the game feels faster overall.

    In Street Fighter 2 fighters seem to move faster then normal. I'm not too good at the game but when I play in FS-UAE I can beat CPU in the first round of the first opponent, in Amiberry sometimes I can't even decide how to hit the CPU.


  • I made a little video:

    that compared to:

    I thinks it's a little faster. Am I wrong?


  • @nemo93 can you share your uae file for OnEscapee please. I have been trying all day to get that game loading. I'm using the hdf file which was made freeware.

    Thanks
    Sim


  • Please help with common issue, hopefully.

    I've RetroPie, all packages in lastest version (10/2020), AmiBerry build from source.

    My game runs OK as LHA WHDLoad package. By public WHDLoad package database game also supports:

    TRAINER TOOLTYPES:
    Custom1=1 for unlimited lives

    So, I want to set-up Custom1=1 for my game.
    Is possible to create game-context file with this specific settings?

    Where (what system path) is best place and how exactly it must look?

    I'm sorry for this simple question but for is not ...
    Thank you very much ...


  • hello all!

    @alchemist what game(s) are you trying to enable trainer(s) for please? Also what is the filename of the package you're trying to run? The very latest Amiberry releases (3.2+) will direct you to a Workbench page right after you launch a LHA package for you to select a trainer. This is true only if the package does have trainer enabled. If true then you could pick an item to enable depending on what's available. If you don't see that trainers page then it's likely you don't have latest Amiberry or package doesn't have any trainer available.

    @Simrose here you for OnEscapee: https://pastebin.com/6ywGmRzw

    @silentheaven83 if you got a feeling that a game is running faster than it should let's have a closer look then :) It occurs to me for the Body Blows serie. This might be due to the default settings applied by Amiberry and picked from the whdload_db.xml file. Yet let's first ensure you have at least the 3 marked Kickstarts in your Retropie BIOS directory as indicated on that page. Second can you please confirm the exact packages names you're using for Kick Off and SF2 please? If you are aware of other similar issue for other games please let me know.


  • @nemo93 Yes, I'm sorry for incomplete question.

    Amiberry 3.3 (2020-09-17) ; Game is R-Type, package: RType_v1.4.1_0940.lha [http://www.whdload.de/games/RType.html] .
    By documentation it looks like this:

    TRAINER TOOLTYPES:
    Custom1=1 for unlimited lives
    Custom2=1 for invulnerability

    From other games I know that Workbench question for enabling trainers, but here it's different ....

    Thank you all ...


  • hi @alchemist no worries at all. Thanks for sharing more details. Indeed that game doesn't have any trainers (or "custom") detected by the script in charge of generating the whdload_db.xml file. I'll have a deeper look but I'm afraid there won't be any quick fix anytime soon. Meanwhile I've found that in case it helps => http://www.lemonamiga.com/games/cheats.php?id=918


  • @nemo93 Hi, in meantime I found this solution:

    1. In Amiberry Configuration GUI select: Configurations > Save
    2. It creates new UAE file at: [config_root]/amiga/amiberry/conf (in my case: RType_v1.4.1_0940.uae)
    3. edit RType_v1.4.1_0940.uae file and find line: "whdload_custom1" set it to 1 (by default set as whdload_custom1=0 ; bottom of file)
    4. try it in game, should works :)

    Reference of Custom configration - Amiberry Wiki: https://github.com/midwan/amiberry/wiki/WHDLoad-Auto-booting


  • Awesome findings @alchemist! I have to apologize this turn as I completely forgot about this new behavior from Amiberry. Indeed it was possible to edit directly a temporary file to add/modify any "custom" config. Since 3.3 it's possible (and more elegant) to edit a config file instead. Exactly as you explained! Thanks for that and for reading the doc ;-) Glad to see it working!

    EDIT: I've added a line about that into the 1st post. Thanks again.


  • Hi all, I'm running v4.5.13 on a Pi 3B+, and having some input lag on Amiberry.

    Read through a few threads on input lag but none that I could find concern Amiberry, hence the new post.

    It occurs with all games, and I've tried two different TVs of different sizes (both set to Game Mode). Amiberry has a Frameskip option but this just made it jittery.

    Is there a 'run ahead' tweak I'm missing with this emulator? Or, any other suggestions? Thanks.


  • @che_don_john There is no run-ahead in Amiberry. I don't know if there are other tweaks that might help though (maybe some frame buffering levels can be changed). Amiberry is based on WinUAE, so you might get some answers by searching on that. Stuff like this. Even though that thread is old, it's about stuff concerning input polling.


  • hi @che_don_john! I'll have more questions for you :) Are you able to quantify the input lag please? How many seconds delay? Or is it more a "feeling" that you have? If you have some examples with some games (don't forget to report the names of the packages used) that would be great. Also do you have similar behavior on other emulator(s)?

    I'd advise you to update Retropie to the latest version (4.7) and do the same with Amiberry (3.3) - update from source. Perhaps that would help.

    To have your TV sets to rely on game mode is good.


  • Have just updated to a Pi4. Downloaded the official RETROPIE Pi 4 image and loaded to an SDCARD

    From my Pi3 I backed up the following:

    bios Share
    configs Share
    roms Share

    I have copied all these back onto the PI 4 and have everything 99% right with the exception of the Amiga and AMIBERRY. When I select any game from the list in emulation station and launch it (games stored as .lha files). I get a blank screen for a few seconds, then I get the grey to white then the classic amiga hand appears holding the disk for V1.3. Its like the path to the game has been lost.

    If I press F12 and select one of the tweaked configs I have done for an LHA game. EG: Batman and load that then restart the game starts

    Any help would be appreicated. I am assuming its a config file somewhere

    Thanks
    Dwarfboysim


  • Hi @Dwarfboysim, I had exactly the same issue when I migrated a few days ago from my Raspberry Pi 3B+ to a new Raspberry Pi 4B with a new Retropie 4.6 image but restoring all my bios / roms / configs folders from my previous configuration. Everything worked as expected, except Amiberry with WHDLoad games (.lha).
    Well...
    I deleted the /opt/retropie/configs/amiga folder (press F4 while in EmulationStation then type : sudo rm -R /opt/retropie/configs/amiga )
    I reinstalled Amiberry from binary
    And... the problem is gone!
    WHLoad games are working again.

    Apparently, they changed the command line arguments in the last Amiberry release. Maybe, it was the cause.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.