Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[SOLVED] Famicom Disk System save state issues still present?



  • I created 2 new systems, famicom-mini and sfc-mini, to replicate the Mini Collection series from Nintendo. 2 new rom folders (famicom-mini and sfc-mini) added entries into es_system.cfg and created the necessary gamelists and images/marquee/video folders.

    I wanted to keep the Japanese game selection exact same as the original Mini systems. For the sfc-mini (Super Famicom Mini) all games are snes games and therefore no issues there thus far. For the Famicom Mini however 4 games are from the Famicom Disk System.

    Akumajou Dracula
    Zelda no Densetsu
    Link no bouken
    Metroid

    All those games have this create save state feature and that feature doesn't work or better say doesn't save any state nor names for all 4 fds games.
    I tried both nes emulators, lr-nestopia and lr-fceumm still save states are not saved.
    I can however use the core save and load state which is OK.

    I just want to confirm that this save state issue is a known thing for fds games. Or was there an update that I missed?

    And to comply with forum rules here my specs

    Pi Model or other hardware: (B, B+, 2 B, 3, X86 PC etc..) Raspberry Pi 3 Model B
    Power Supply used: (If using a Pi) DC 5V 4A
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.2.12
    Built From: (Pre made SD Image on RetroPie website, Berryboot, or on top of existing OS etc.. - please provide the filename of any image used) file from RetroPie website
    USB Devices connected: 2x MicroUSB cables to charge 8bitdo controllers, Xbox360 RF unit, USB extension for keyboard and second Arcade Stick
    Controller used: 2x FC30 8bitdo, custom Xbox360 wireless arcade stick, custom Bufallo arcade stick
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant): not needed for this issue
    Guide used: (Mention if you followed a guide) None
    File: (File with issue - with FULL path) Not needed for this issue
    Emulator: lr-nestopia and lr-fceumm
    Attachment of config files: Not needed for this issue
    How to replicate the problem: run Akumajou Dracula, Zelda Densetsu or Metroid for Famicom Disk System



  • I'm not sure I fully understand the problem you are having, but I've been playing Doki Doki Panic with save states, and things seem to work just fine (Select + R and Select + L). I'm playing with lr-nestopia on a Pi 3.

    I'll give one of the games you're having an issue with a try and report back.





  • I just tested with Akumajou Dracula and it works fine. I'm on a newer version of RetroPie (4.3.3) but I don't know that it matters as I've never had an issue with save states on FDS. I checked and the version of Nestopia is "1.6.7 - Nestopia 1.49-WIP d86e1ad"

    Here's a video example (excuse the potato iPhone footage, I don't know of a great way to record video directly from the Pi). Is this what you mean?



  • Maybe I have not explained it very well.
    The save state and load state from the lr- core works just fine for me too.
    In obsidionspider's video at the beginning where he writes the OBS... name that is or should be the in-game save feature. Same like in SNES Zelda a Link to the past where you input a name and start to play. That in-game save feature doesn't work for any FDS game.
    So every time I start to play Dracula or Metroid or Zelda on FDS I have to either use an existing in-game save or create one.
    Of course once I am in I can just save via retroarch core and be done with it. I was just not sure if only I have this in-game save state issue or if it is a general problem in FDS rom games.

    @obsidianspider

    To actually see what I mean you just load that game again and check if your created in-game account OBS... is still there or not.



  • Correction to above statement.
    Metroid, Zelda Densetsu and Link no Bouken do create a .sav file using nestopia as core.
    Akumajou Dracula doesn't no matter which core you use. Well I guess I can live with that as long the core save load state (.state file ) works.



  • @flyingtomahawk Have you tried to make a blank save and rename it to the same name as the rom?



  • @rion
    Yeah, just tried and it didn't work. It seems to be happening only with Akumajou Dracula so I'll just have to accept it and use the core save/load function.



  • @flyingtomahawk Maybe there's a fix? Have you checked romhacks?



  • @FlyingTomahawk

    So, I did some reading on this, and it turns out that the only way to save the game in Akumajou Dracula is to get a game over. At that point you can continue or save. I tested it and it works fine with lr-nestopia. Here's a video I made of it working properly. Saving is kludgy and slow, but I guess that's what you get for 1986 technology.



  • @obsidianspider

    Ha! That actually worked.
    Who would have thought about that. Except you of course. I was too proud to let my character die on purpose so never tried it that way. ;-)

    So for Dracula you have to die till Game Over then you are able to save. Other FDS games like Metroid or Zelda on the other hand can be quit anytime using the lr- core exit function, in my case SELECT + START, and the game still saves.

    Cool, so this is solved I guess. Thanks for all the help and the video. I am sure this will be helpful to others in the future.



  • @flyingtomahawk I’ll admit I did some searching to look into where save points were in the game since I am not very good at Castlevania and I didn’t know where FDS would ask you to save. I’m glad the issue is resolved.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.