Please do not post a support request without first reading and following the advice in

[SOLVED] Famicom Disk System save state issues still present?

  • I just tested with Akumajou Dracula and it works fine. I'm on a newer version of RetroPie (4.3.3) but I don't know that it matters as I've never had an issue with save states on FDS. I checked and the version of Nestopia is "1.6.7 - Nestopia 1.49-WIP d86e1ad"

    Here's a video example (excuse the potato iPhone footage, I don't know of a great way to record video directly from the Pi). Is this what you mean?

  • Maybe I have not explained it very well.
    The save state and load state from the lr- core works just fine for me too.
    In obsidionspider's video at the beginning where he writes the OBS... name that is or should be the in-game save feature. Same like in SNES Zelda a Link to the past where you input a name and start to play. That in-game save feature doesn't work for any FDS game.
    So every time I start to play Dracula or Metroid or Zelda on FDS I have to either use an existing in-game save or create one.
    Of course once I am in I can just save via retroarch core and be done with it. I was just not sure if only I have this in-game save state issue or if it is a general problem in FDS rom games.


    To actually see what I mean you just load that game again and check if your created in-game account OBS... is still there or not.

  • Correction to above statement.
    Metroid, Zelda Densetsu and Link no Bouken do create a .sav file using nestopia as core.
    Akumajou Dracula doesn't no matter which core you use. Well I guess I can live with that as long the core save load state (.state file ) works.

  • @flyingtomahawk Have you tried to make a blank save and rename it to the same name as the rom?

  • @rion
    Yeah, just tried and it didn't work. It seems to be happening only with Akumajou Dracula so I'll just have to accept it and use the core save/load function.

  • @flyingtomahawk Maybe there's a fix? Have you checked romhacks?

  • @FlyingTomahawk

    So, I did some reading on this, and it turns out that the only way to save the game in Akumajou Dracula is to get a game over. At that point you can continue or save. I tested it and it works fine with lr-nestopia. Here's a video I made of it working properly. Saving is kludgy and slow, but I guess that's what you get for 1986 technology.

  • @obsidianspider

    Ha! That actually worked.
    Who would have thought about that. Except you of course. I was too proud to let my character die on purpose so never tried it that way. ;-)

    So for Dracula you have to die till Game Over then you are able to save. Other FDS games like Metroid or Zelda on the other hand can be quit anytime using the lr- core exit function, in my case SELECT + START, and the game still saves.

    Cool, so this is solved I guess. Thanks for all the help and the video. I am sure this will be helpful to others in the future.

  • @flyingtomahawk I’ll admit I did some searching to look into where save points were in the game since I am not very good at Castlevania and I didn’t know where FDS would ask you to save. I’m glad the issue is resolved.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.