Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PowerBlock switch not initiating shutdown.



  • A search for my issue yielded this result, which sounds very similar and was unsolved:

    PowerBlock no longer shuts system down

    I installed the PowerBlock, tested all the switch, power, and led circuits with my multimeter, and everything seems good to go. When I hit the switch, the system starts. Great. The LED light continues to slow-blink, however, as though it's still booting, the entire time the system is on.

    And then the very strange thing: when I hit the switch again to de-latch it, nothing happens. No shutdown, no change in LED blink rate, nothing.

    I've tested that the switch pins have continuity while the switch is latched and then don't have continuity when the switch is de-latched. So the wiring seems fine. I've uninstalled and reinstalled the Powerblock drivers from the Retropie-Setup menu, and made sure they're enabled. I've looked at my /etc/PowerBlock scripts (they just do a "shutdown -h now"). Everything seems good to go, but it's behaving strangely.

    Any tips?


  • Global Moderator

    If the status LED keeps on blinking while the system has fully booted, it is a clear indicator that the PowerBlock driver is not installed correctly: The driver communicates with the PowerBlock to such that the LED should constantly stay on when everything is loaded.

    Have you tried and used the one-line installation as described at https://blog.petrockblock.com/2017/08/17/tutorial-powerblock-retropie/?

    Maybe there is something wring with the installation via RetroPie.



  • Thanks for replying! I did try uninstalling the driver via the Retropie-Setup menu and installing it instead with the one-line method described on that page, and the behavior didn't change.

    If you're sure that this is a driver install issue, I may try starting with a clean system and seeing what happens.

    Additional info:
    Raspberry Pi 3, revised version of the Powerblock, the CanaKit power supply (2.5A, 5.1v), newest version of RetroPie (4.3) updated via setup script.



  • Update: I started with a clean install of 4.3, and installed the PowerBlock driver with the one-line method. No luck. I then ran the PowerBlock uninstall script and tried installing and compiling the driver from source. Still no luck.

    The behavior was the same in both situations -- the LED continues to slowly blink, and turning the switch off has no discernible effect whatsoever.

    My PowerBlock is wired for power via the 5v Input pins. I tried plugging the power supply straight into the PowerBlock's microUSB jack, to see if that would make any difference. It didn't.

    I'm stumped and would appreciate any further help.



  • Here is the full output of my one-line install command. This ends with "SUCCESS" messages, but the LED continues to blink slowly, and switching it off does nothing, even after a reboot. There are some warnings during compilation, mostly unsupported tags in the Doxyfile.

    PowerBlock_install_output.txt


  • Global Moderator

    Can you post a photo of your hardware setup?

    Also, you can contact me via email so that J could send you a replacement if we do not solve this issue soon. Would that be ok?



  • I have got exactly the same problem... any news or solution?


  • Global Moderator

    @brinkbeat Would you please start your own thread? Thanks!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.