Please do not post a support request without first reading and following the advice in

Solved: Steven Selph /scraper not found

  • Pi Model or other hardware: Pi 3, Model B, no overclock
    Power Supply used: 5V, 2A
    RetroPie Version Used: 4.3.5
    Built From: Image on RetroPie website
    USB Devices connected: Anker keyboard
    Controller used: 8bitdo SNES30
    Error messages received:

    Could not successfully install Scraper for EmulationStation by Steven Selph
    (/home/pi/RetroPie-Setup/tmp/build/scraper/scraper not found)

    Guide used:

    Emulator: EmulationStation
    Attachment of config files:
    How to replicate the problem:

    • Following the guides provided (either one) error is received every time.
    • Log file created everytime it errors out
    • Errors out at the same point every attempt
    • I am using sudo to initiate the setup
    • I am unable to add the /scraper folder using sftp with admin login

    There are possibly several issues that caused this, I will list here everything I noticed that could be related

    • SD card had error and would not re-format while conducting a fresh install
    • I may not have expanded the default RetroPie disk usage (cannot confirm as SD card was corrupt)
    • Fresh install with new SD card solved the issue

  • @frankenbenz Have you tried installing the scraper using the setup script through the menu in Emulation Station?
    Go into Configuration > RetroPie SetUp . UPDATE RETROPIE -SETUP SCRIPT then Manage Packages > Optional > Scraper

  • @jonnykesh
    I have used the menu in Emulation Station as well. I did re-run the update setup script just now and then re-ran the scraper through the menu. Same issue present.

  • @frankenbenz Odd. I just un-installed and re-installed with no issues. Obviously this may not be the same as a fresh install but it threw no errors at all.

  • @jonnykesh Maybe I will try re-installed RetroPie and hope for the best.. :/

  • @jonnykesh
    I did a fresh install and it is working okay now. I did pick up a new SD card as my previous one was having an error while reformatting.

    Issue is solved.

  • @frankenbenz Good to hear. If there was a general issue with the scraper install we definitely would have heard more about it by now.
    Sometimes things just get screwy for no obvious reason. Computers, eh?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.