Please do not post a support request without first reading and following the advice in

USB Controller not working / esc button stopped working

  • I have a generic usb controller similar to a dual shock

    Previously I have used a basic gamepad with everything working fine using keyboard esc to exit games.

    Since obtaining the new controller i have been unable to map all the buttons as it will not map the analogue sticks and the esc key on the keyboard has stopped exiting games.

    any advice would be appreciated, I tried using retroarch to map the buttons but this was when the esc button stopped working (start and select didnt work as an alternative either)

    Any advice or pointing in the direction of a guide would be apprecaited many thanks in advance.

  • ok think ive managed to get the controller working despite it not allowing me to configure the sticks.

    but cant exit out of games using the keyboard any more and pressing start and select on game pad doesnt work

    The only way I get get out of games is to turn off the power any advice on how to solve this would be appreciated

  • ok it appears the controller for player 1 is not working properly ?
    when pressing down it does not work in game however in menu it does?

    Player 2 works fine though also tried switching controllers and it makes no difference.

    I have tried remapping buttons in retroarch but it doesnt seem to help

    also still am unable to exit games without powering down

  • Ok have resolved this issue by performing a fresh install after backing up roms via network

    Installed using retropie v4 video

    installing controller from fresh install all works fine, 2nd player works fine too

    also start & select now exits games

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.