Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sega CD Roms will not load from USB



  • Firstly, I am certain I will do something wrong in posting, please don't be too harsh. I am trying to follow the rules, but I am sure my formatting will be bad. On top of this, I have owned my first Pi for a total of 3 days and am an absolute beginner trying to do it all on my own.

    Pi Model or other hardware: 3B
    Power Supply used: Proper one from CanaKit
    RetroPie Version Used: 4.3
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Transcend 32gb USB thumb drive
    Controller used: Buffalo Classic USB Gamepad (SNES)
    Error messages received: Sometimes - failed to start usbmount dev sda service
    Guide used: https://github.com/retropie/retropie-setup/wiki/Transferring-Roms
    File: (File with issue - with FULL path) retropie/roms/segacd/Lunar - The Silver Star (Sega CD) (U).bin (and a .cue)
    Emulator: ??? I am using what the system came with. Emulation Station ???
    How to replicate the problem: Actually, I tried to load 5 Sega CD games at once via USB and would always get that USB mount error message and nothing would be in the system. After that, I changed to just one at a time (Silver Star most recently) and, I do not always get that error, but it does still boot the system with no Sega CD option.

    I should note that I began by loading NES, SNES, Sega 32x and Megadrive games with no troubles and all of them play properly. There was nothing, but once I added the ROMS to the USB thumb and plugged it in, it auto added and then showed me those options.
    As far as I can tell, it adds nothing for Sega CD because no option comes up on the screen once the system boots up, just all the same systems I have previously listed.

    I should note that I wondered if it was due to file size, so I tried to see if I could do an FTP transfer since Pi 3B has wifi. I was able to get it connected online, and then followed the same guide as listed above, but from the SFTP option. I downloaded the WinSCP file and followed the steps shown, but I could not get it to connect to anything after adding the information I thought I needed.

    Sorry to be troublesome and a complete n00b.


  • Global Moderator

    @dv8mad You need to enable SSH first before using WinSCP - see the docs https://retropie.org.uk/docs/SSH/. After you enable it, then you can use WinSCP and transfer the CD images.
    But you'll get the same result if you transfer the files over file shares, copying them via file shares in \\retropie\roms\segacd. Make sure that the files have the proper case, i.e. .cue vs .CUE, and the .cue file (which is a normal text file) also has inside the correct .bin filename. Remember that Linux has a case sesitive filesystem.
    Once you have copied the files, restart Emulationstation and see if the system shows up with the games. If they don't, check the log in /home/pi/.emulationstation/es_log.txt via WinSCP and see if you get any errors there.
    More information about Sega CD games you find in the docs - https://retropie.org.uk/docs/Sega-CD/.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.