Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PS4 Controller with Sega 6 Button Games?



  • I recently received a Raspberry Pi for Christmas and am slowly learning how to work this thing, but I'm having trouble with getting Mortal Kombat 2 to play correctly. I'm using 2 PS4 controllers, and retro NES controllers for NES games, but I can't get the emulator to let me use the PS4 controller like a 6 button Sega controller.

    I correctly assign all of the buttons in the EmulationStation (it recognizes every button on the ps4 controller), but when I load the game, it acts like I'm playing with a Sega 3 button controller. So I can't throw a low punch. Is there a way to change this?

    As a 90's kid, this emulator is SO freaking awesome. I'm trying to load tons of games onto my Pi so I can invite my buddies over and relive our childhoods!

    Thanks for the help!



  • @yourrid Please supply the details requested in https://retropie.org.uk/forum/topic/3/read-this-first as you do not provide any information. Mortal Kombat 2 on which emulator? On which Pi? for example.



  • My apologies:
    Pi Model or other hardware: Pi 3B
    Power Supply used: Pi power supply
    RetroPie Version Used: 4.2
    Built From: Came Pre-installed from Vilros NES kit
    USB Devices connected: PS4 controller
    Controller used: PS4 controller
    Error messages received: None
    Guide used: Used the controller config guide on RetroPie
    File: (File with issue - with FULL path)
    Emulator: Mortal Kombat II (32x), Mortal Kombat II (world), Mortal Kombat II Unlimited V1
    Attachment of config files: Not sure how to do this
    Using EmulatorStation V2.1.5RP



  • @yourrid said in PS4 Controller with Sega 6 Button Games?:

    Built From: Came Pre-installed from Vilros NES kit

    Please read point 5 of https://retropie.org.uk/forum/topic/3/read-this-first. 3rd Party images are not supported because nobody can know how the seller has setup the software which is illegal to sell by the way because Retropie is free. Please format the card with the latest image so that we have a reference point in order to best support you.

    Emulator: Mortal Kombat II (32x), Mortal Kombat II (world), Mortal Kombat II Unlimited V1

    These are games. These are not emulators. What systems are you emulating? Arcade? SNES? etc with which emulator?



  • @rbaker

    I understand your concern of me purchasing something that is free. I'll have to format the SD card and flash RetroPi back on it tomorrow. I just realized the USB keyboard I bought to use with the Pi has a PS/2 connection rather than USB (oops, back to Fry's).

    I'm using EmulationStation to run Sega 32x (Sega Genesis)



  • @yourrid When you have re-flashed, follow the autoconfig at first boot and see if you still have the issue. If you do, come back and reference which Genesis buttons you have mapped to which PS4 button etc.



  • @rbaker Will do. I appreciate your help!



  • The kit has nothing to do with this issue. You just have to enable the 6 buttons in the config



  • @yourrid before you start a game, press a, change button config. That should sort this



  • @jste84 Ok, I'm working on flashing the latest RetroPi. If this doesn't fix it, I'll give it a shot. Thanks for the help!



  • @yourrid yes having read again the latest build should work I believe...



  • @Jste84 @rbaker So I formatted the SD card, flashed the newest version of RetroPi, then loaded some games on my USB drive, and still no extra button.

    I even tried Street Fighter II - Special Champion Edition which is supposed to run on a 6 button controller, but it reverts to 3 buttons only. I put in Mario Kart 64 (ran on the N64 emulator) and all of the buttons function... so the Pi is recognizing me pushing the buttons. Seems like the ROMs themselves don't want to work with the extra buttons.

    I did push A before the game started to look at the config menu. But there isn't anything in there for me to edit the controller buttons. I can choose which emulator to use, video mode and a few logging options, but no button config.



  • @yourrid use lr-picodrive. Go into the retroarch gui. Go into quick menu then options. Change your controllers from 3 button to 6 button



  • @edmaul69 DING DING DING DING!! Edmaul69 wins!

    So there is a sub menu for configuring the controller for the Sega, which is in the Retroarch GUI. But you can't use the Retroarch in the main RetroPie menu. You have to launch a rom, then open the Retroarch menu by using [select + X]. Here's the weird part, the menu doesn't always pop up. I found that you have to be selecting a player for it to work (doesn't work at the start menu). Along with that, the controller config is totally different than what you set in EmulatorStation at the beginning. So Select and X might not be the same buttons you assigned. You can select 6 button, and then assign the buttons.

    I guess EmulatorStation assigns buttons for navigating RetroPie, but you need to reasign them in Retroarch for games with different types of controllers... like trying to get a PS4 controller to work like a 6 button Genesis controller.

    Thank you everyone for your help!



  • @yourrid in lr-genesis-plusgx you are supposed to be able to switch between 3 and 6 button with the select button but it doesnt work. And strangely some 6 button games default 6 buttons and some dont. So i just use lr-picodrive. Problem solved.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.