Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PS4 Controller with Sega 6 Button Games?



  • @yourrid When you have re-flashed, follow the autoconfig at first boot and see if you still have the issue. If you do, come back and reference which Genesis buttons you have mapped to which PS4 button etc.



  • @rbaker Will do. I appreciate your help!



  • The kit has nothing to do with this issue. You just have to enable the 6 buttons in the config



  • @yourrid before you start a game, press a, change button config. That should sort this



  • @jste84 Ok, I'm working on flashing the latest RetroPi. If this doesn't fix it, I'll give it a shot. Thanks for the help!



  • @yourrid yes having read again the latest build should work I believe...



  • @Jste84 @rbaker So I formatted the SD card, flashed the newest version of RetroPi, then loaded some games on my USB drive, and still no extra button.

    I even tried Street Fighter II - Special Champion Edition which is supposed to run on a 6 button controller, but it reverts to 3 buttons only. I put in Mario Kart 64 (ran on the N64 emulator) and all of the buttons function... so the Pi is recognizing me pushing the buttons. Seems like the ROMs themselves don't want to work with the extra buttons.

    I did push A before the game started to look at the config menu. But there isn't anything in there for me to edit the controller buttons. I can choose which emulator to use, video mode and a few logging options, but no button config.



  • @yourrid use lr-picodrive. Go into the retroarch gui. Go into quick menu then options. Change your controllers from 3 button to 6 button



  • @edmaul69 DING DING DING DING!! Edmaul69 wins!

    So there is a sub menu for configuring the controller for the Sega, which is in the Retroarch GUI. But you can't use the Retroarch in the main RetroPie menu. You have to launch a rom, then open the Retroarch menu by using [select + X]. Here's the weird part, the menu doesn't always pop up. I found that you have to be selecting a player for it to work (doesn't work at the start menu). Along with that, the controller config is totally different than what you set in EmulatorStation at the beginning. So Select and X might not be the same buttons you assigned. You can select 6 button, and then assign the buttons.

    I guess EmulatorStation assigns buttons for navigating RetroPie, but you need to reasign them in Retroarch for games with different types of controllers... like trying to get a PS4 controller to work like a 6 button Genesis controller.

    Thank you everyone for your help!



  • @yourrid in lr-genesis-plusgx you are supposed to be able to switch between 3 and 6 button with the select button but it doesnt work. And strangely some 6 button games default 6 buttons and some dont. So i just use lr-picodrive. Problem solved.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.