Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Game ROMs disappearing and reappearing



  • Pi Model or other hardware: Pi 3
    Power Supply used: Official Pi 2.5a, 5.1v
    RetroPie Version Used: 4.3
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: None
    Controller used: PS4/Dualshock 4
    Error messages received: None
    File: \RETROPIE\roms\megadrive\Sonic the Hedgehog.md
    Emulator: n/a

    This is going to sound like the most stupid question ever, but it is doing my head in!

    So, I installed a load of Sonic the Hedgehog ROMs into the Mega Drive folder when I set up my Pi originally (Sonic 1, 2, 3 & Knuckles) but they were hacked/edited ROMs with different characters, different look and feel etc. I've had my Pi switched on, navigated to \RETROPIE\roms\megadrive on Windows Explorer and deleted ALL the Sonic the Hedgehog named ROMs to replace with original, unhacked versions.

    The unhacked versions will open and play once I've restarted Emulation Station but once I restart for a second time I'm back to having all the hacked versions I just deleted!

    I've tried deleting then restarting the Pi, then copying across the unhacked versions and restarting the Pi and that works once, but restart again and I am back to square one.

    I've extracted the .md files from the zip and made sure there is just Sonic 1.md, Sonic 2.md and so on, but the other ones still come back!

    I have no hard drives or thumb drives plugged in that the Pi could be copying the hacked versions across from so I don't know what is happening.

    I told you it would be a stupid question, but where am I going wrong?!



  • @mistermints My first guess is that your card has gone into a read only state. Try copying across a file that is unique. Check it is there, then reboot. Check again. If it is gone it may be an issue with write permissions to your SD card or your card may be on its' way out.



  • @jonnykesh how does a micro SD card go into a locked/read only state? And how do you get it out of that state?

    The SD card is fairly new. I bought it a couple of months ago to use with my phone, before switching to a 64GB one for that, so the Pi is using a 32GB almost new (literally only used in the phone for about 4-5 weeks).



  • @mistermints SD cards go read-only when they are about to die. It's a function of the card. If it happens there isn't much you can do about it. It exists to allow you to recover as much data from the card as you can before it becomes unreadable.
    However, that might not be your issue. Did you try transferring the file as I suggested? What happened?



  • @jonnykesh Not had a chance to yet, but will report back ASAP.

    Thanks



  • @jonnykesh Problem solved! Thankfully it isn't a problem with the SD card dying, or anything else like that - its the crappy Scraper pulling incorrect information down.

    I had set the system to decide on conflicts, not thinking that it would confuse say "Sonic the Hedgehog.md" with "Sonic the Hedgehog 3 and Knuckles.md".

    So all I have to do now, is go back into each of the 3000+ games I have installed across multiple systems, and fix each one!



  • @mistermints fun times!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.