Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

rpie on ubuntu



  • Hi there, im new here and rpie stuffs so, in general, I need your help :)

    I found an old laptop with broken lid, so, I installed Ubuntu 17.04 and Ubuntu Rpie. Everythings works fine, but lr-snes works but with a very perceivable input lag. Then I intalled retroarch and cores from libretro repositories and input lag dissapear completely with snes9x2010 core.

    You could say... input lag is very hard to notice for an human being XD, but im an old and experienced 2D old school fighting games, so I really can notice the difference between a delay and a responsive control, specially in Super Mario World (very noticeable).

    My lap is an apu e1-2100 (cpu 1ghz) with integrated Radeon HD and 2gb ram.

    I know is a crappy lap, but for arcade, 8bit,16bit emulation and hd tv shows player works great, and as I said before, retroarch from libretro cores works whith almos zero input lag...

    So, my question is.... Is there anyway to link rpie emulationstation with cores from libretro, instead rpie cores??? rpie emulationstation is sooo good.

    Im not english native, so i hope made myself understand :)

    have a good day and thanks :)



  • @george_woody I don't know where you got this info, but there's no such thing as retropie cores, RetroPie bundles RetroArch and it's various cores, from the Libretro project. There's no emulators developped specificaly by the RetroPie project.
    If you're happy with lr-snes9x2010, then you can make it the default emulator for SNES and go play.
    More information about the emulators and their origin are found in the documentation, there's a dedicated section for each system.



  • @mitu thanks for response, and sorry if i misunderstood something :)

    the thing is.... lr cores (whole package, cores and ES compiled follow the instruction in this page for ubuntu) works perfect, but, for example, lr-snes, the input lag in super mario world is very noticeable; in the other hand, i installed retroarch from repositores, with its cores binaries, and snes9x2010 (from libretro repositories) works perfect without noticeable input lag...
    I assumed that the "lr" is the name from cores specially designed by rpie team

    Is not a big deal, but noticeable input lag is very annoying, specially when YOU actually can notice...

    thank you :)

    PD: the other thing I notice is the "HARD GPU" option is not available in rpie retroarch. In retroarch installed from libretro repository is in "video options" and making enable always helps, in my case, to reduce input lag. Maybe if I could make it enable in rpie options...



  • @george_woody said in rpie on ubuntu:

    I assumed that the "lr" is the name from cores specially designed by rpie team

    Yes, but it's just a name to differentiate between non-libretro emulators and the libretro ones.

    PD: the other thing I notice is the "HARD GPU" option is not available in rpie retroarch. In retroarch installed from libretro repository is in "video options" and making enable always helps, in my case, to reduce input lag. Maybe if I could make it enable in rpie options

    I checked and this option is available for me - but I'm on a RPI system and not on x86. Maybe you need to enable 'Show Advanced Options' from the 'User interface' configuration section ?



  • @george_woody Hey, I just checked on my PC running Debian 9, RetroArch 1.6.9 and the Hard GPUoption is available under the video options.
    Which version of RetroArch are you currently running? If you are up to date it should be the same as mine.



  • Im updating right now my whole system. So, when its finished, i'll let you know.
    Another thing is psx mednafen (not hw) runs very slow. N64 dont event try it. But i blame to my crappy cpu, so if you have any advices to optimize it, would be great.
    I read the doc section, and you are right, libreteo cores are compiled directly from source.

    Have a very nice day ;)



  • Well, after make a complete update of the whole system, the problem persisted (HARDGPU option now is there;) ) , so, what I did is replace the "lr-snes9x2010" core with the binary precompiled, and the input lag dissapear. So now the problem is "SOLVED"

    Thanks



  • Thanks for sharing your solution.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.