Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie on top of Mint - autostart issue, terminal window



  • Hi,

    I dig through the forum but can't find answer to the problem I have.
    I'm trying to build dedicated Linux box since 4.1 RetroPie, recently i've tried 4.3 and Mint 18.3 setup on x86_64 PC. Everytime i'm building the RetroPie from scratch. I did that many times and all the time end with same issue: when I choose to autostart RetroPie after restart I end with overstretched terminal window (more than fullscreen) instead of ES screen. This is problematic as the terminal window cannot be closed - just switched using alt+tab to the ES screen. Now, when you want to have keyboardless setup then this is a problem.

    Any ideas how to solve that? Some edits to autostart script? I went through it but cannot find section which is causing this.



  • Heh, replying to myself but I sort of managed to fix this. I don't know if this is a bug or feature but during autostart gnome-terminal is launched with "--fullscreen" option instead of "--maximize". The first one apparently forces terminal to be on top of any window and that's why ES screen is not.

    Now, it seems to work as expected.



  • Thanks for sharing your solution.



  • @tomeq82 how did you change to --maximize? Having the same issue on an all in one running Mint+Retropie



  • Hi,

    I had RetroPie running on Mint for a short time and I didn't need to mess with the fullscreen options. All I did was add a startup delay of 3 seconds to the RetroPie entry. This stopped the issue. I would leave it as fullscreen and try that? I think this happens because if ES starts before X is running it doesn't launch. Not sure though but a slight delay should resolve.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.

Looks like your connection to RetroPie Forum was lost, please wait while we try to reconnect.