Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Remove auto login text at boot


  • @mancity What happens if you remove the console=tty1 from /boot/cmdline.txt (or change to console=tty2)


  • @Floob I have it set to console=tty3 as per the guide. What's the difference between 1, 2 & 3?

    Also console=tty is in cmdline.txt twice but at the beginning it doesn't have a number at the end?

    I'm using a Pi B+ with latest retropie image


  • I have the same thing console=tty twice. Here's my /boot/cmdline.txt file:

    dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty3 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet loglevel=3 consoleblank=0 quiet loglevel=3 logo.nologo

    Here's my original /boot/cmdline.txt file:

    dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet loglevel=3 consoleblank=0

    EDIT: Still my screen is clean from anything I can see on bootup. I'm running a RetroPie 3.7 on a Pi 3 with the updated script but not binaries.


  • @Riverstorm my only difference I think is the order of some of the comments. I might try your order tonight. Mine has console=tty3 toward the end.

    Deleting both entries of console=tty makes no difference

    Interestingly, I removed 'quiet' and it's stopped showing the login text 9 out of 10 times, leaving just a flashing '_' for a 2 seconds, before moving onto the Emulation Station splash screen, so now I'm really, REALLY confused haha.

    On a plus note I'm learning quite abit :)


  • The tty is basically a text output location, by default the screen is tty1, so by changing it to tty2 for example is sending the text output to somewhere you cant see - unless you decide to switch to it. So dont remove console=tty1 just change it.


  • When I removed console=tty1 everything was still clean for me but when I removed console=ttyAMA0,115200 I had about a half dozen lines right before the RetroPie logo screen but nowhere else. I was doing it more for comparison than anything else as it does work well on the Pi 3 vs. Mancity is using a B+ I think. I am not sure if that's the main difference because my boot is clean as a whistle.


  • So, just literally bought a Pi3 (B+). Put a new install of RetroPie on and added the lines "console=tty3 quiet logo.nologo" to cmdline.exe and STILL see the automatic login!

    So there's no way im the only one?


  • @mancity said in Remove auto login text at boot:

    So, just literally bought a Pi3 (B+). Put a new install of RetroPie on and added the lines "console=tty3 quiet logo.nologo" to cmdline.exe and STILL see the automatic login!

    So there's no way im the only one?

    did you add those as new lines? I believe that file should only be 1 line in total and the "console=tty3" part should not be "added", rather you should change the existing setting


  • @ProxyCell
    Yeah exactly that. I changed console=tty1 to 3 and then added quiet and logo.nologo directly after and the whole thing is on a single line.

    I literally dont understand what I'm doing wrong I though oh maybe it's because I'm using a Pi B+ but obviously not. It's a complete fresh retropie image too which I have just downloaded and the only single change I made because I was testing was to cmdline.txt

    I'm baffled what I'm doing wrong :(


  • Also does everyone manually remove the motd test or does that not show for them as well?


  • So... I moved the Pi 3 downstairs last night to use in the front room, and since then, the automatic login hasn't appeared. The ONLY difference is there now isn't a keyboard attached.

    Surely that not it?

    PS - On the Pi B+, still happens.


  • How long does the output "linger"? Is it seconds or just a flash? I don't have any more thoughts as for me it was literally a few seconds to tweak and it worked perfectly according to the Wiki. Maybe you could paste the contents of your cmdline.txt exactly as it appears.

    It may sound overly simplified but it seems you must be doing something different as no one else has come forward with the same issue. Is it possible you're doing some step that you're certain wouldn't be the issue is possibly the culprit. I've done that a few times and had a eureka moment. You might have to scrutinize every change you're making. The answer has to be there.


  • Well when it shows, it lingers for about 2 seconds, but using my Pi 3, I think the issue is solved .


  • @mancity said in Remove auto login text at boot:

    Well when it shows, it lingers for about 2 seconds, but using my Pi 3, I think the issue is solved .

    Ok, great, so the Pi 3 is working properly it's just the B+ then that was giving you issues?


  • @mancity For me, this question also remained topical, and I have found a solution.
    you need to open raspi-config, choose "boot option", select the second item "wait for network at boot", and click "No".
    thus, there is no more text.



  • @linuxarcadeguy I am the same.OTL
    Did you solve that?


  • @tanakarena solved! look up


  • @LinuxArcadeGuy thanks very much, your comment fixed my issues.. that autologin text was painfull the the console feel i was looking for


  • @linuxarcadeguy

    Thanks for the instructions, however I'm still getting two lines of data.

    The first saying the last time I logged in like time and date then tyy1 at the end

    The second saying Linux retropie with the build which is December 22nd

    Any ideas?

    Cheers

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.