Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sselph scrapper getting strange results



  • I'm having an issue with scrapping and looking for some help. Yesterday on my pi3 (fully updated as well), I went to scrape and append new roms with sselph scrapper I had weird results. The gameslist name filled out the rom names as .hack-Link and saved no descriptions. Prior to this I had all correct images and video snaps working. The images are named correctly as well but all have the same PSP .hack-link image. I deleted all the games lists and images and re-scrapped all my roms again. Same result. Some systems were ok but others like Nes were now all displaying this hack-link info.

    This morning I am trying but system only, atari 7800, and same result. I've followed ETA prime scraping video as I did the initial time which worked perfectly. I have the scrapper setting the same as that first time I did it but just keeps pulling down this .hack-link stuff.

    From what I found the is a PSP game called.hack//LINK on the web. A scene hacked version of some psp game I guess? I don't have this game at all and I don't get why more than half of my roms in the gameslists and images are pulling down this image. Could the screen scrapper website have something on their end going on causing this?

    Here's a screen shot of the atari 7800 image that every rom now has, the 7800 folder with the image roms named correctly and the xml showing how the name and descriptions look now. https://imgur.com/10Agz7V

    Anyone have this happen or know why this is happening? It's driving me crazy and don't know how to get it back to normal.

    Thanks



  • Same problem here, I have no idea what's going on.



  • Same thing for me. I notice if I select the games to play them, they are actually different games. But they all look the same on the menu.



  • Good to know it's not just me. I thought I might have been done something to mess up my build up. Hopefully someone knows whats going on because I have no clue how to get it back to normal.



  • I had the same problem. I've noticed it happens to rom hacks and some Japanese games. I'm assuming these would be the roms the scrapper would normally skip anyway.

    Now one problem I'm having is Wonderswan and Wonderswan Color, both are returning 0 results. Anyone else?


  • Global Moderator

    @fabio78 said in Sselph scrapper getting strange results:

    Now one problem I'm having is Wonderswan and Wonderswan Color, both are returning 0 results. Anyone else?

    Check if the scraper supports this system - https://github.com/sselph/scraper.



  • @mitu Ha! It doesn't. You're very perspicacious, mitu :)
    (Though the documentation doesn't list Atari 5200 and 7800 and I can confirm it scrapes then, including video snaps.)



  • I scrapped my roms last night and now all my NES games show as .hack-link was well as 20% of my Mastersystem, megadrive and SNES games. is there any way of undoing this? I have scrapped these systems before with the same roms without any problems.


  • Global Moderator

    @lacara Try changing the scraping source to thegamesdb, based on the reports in this topic I thing the default source (screenscraper.fr) has some problems.



  • Ok, I'll try that tonight and see how it works.



  • @pickaxpete Any luck?



  • This is why I use UXS, it scrapes based on the hash, it doesn't care what the system is as screenscraper will tell it what the system is from the hash.

    I don't understand why sselphs one is system limited if it is using screenscraper as the source.



  • @squeez52, I tried sselph again yesterday, no luck. Downloaded UXS and ran it on one rom folder on my PI and worked great. Now I'm scrapping my rom folders on my PC and will transfer the gamelist and images over to my PI when it's done. Seems to take a lot longer than sselphs scraper but it looks to be getting all the images and video snaps. Gamelists I've checked look to have all the correct info as well.


  • Global Moderator

    @bladehunter said in Sselph scrapper getting strange results:

    it scrapes based on the hash,

    In fairness, sselph scraper uses hashes too:
    [ from https://github.com/sselph/scraper ]

    An auto-scraper for EmulationStation written in Go using hashes. [...]
    The script works by crawling a directory of ROM files looking for known extensions. When it finds a file it hashes the ROM data minus any headers or special file formatting with the goal of hashing only the data pulled from the original game

    There is an issue opened on the Github project page which mentions this problem (https://github.com/sselph/scraper/issues/214), so maybe this problem will be fixed.



  • Sselph scraper is working fine for me. I've just scraped some large romsets from scratch (finished half an hour ago) and I can't see any strange entries.



  • @tashman After I read your comment I tried it again. I still get mixed results on my end. I only tried it on some of my rom folders though. Most of those pulled down images and video fine. 2 out of five still grabbed the hack-link image. I scraped gb, gba, gamegear, jaguar which only have a handful of games in them. Those could have been the ones that were mostly good last weekend, I don't remember. The weird thing is when i scrapped videos for atari 7800, the whole folder was hack-link. When I turned video scraping off and just scraped images, the images and descriptions were good in the gamelist and image folder.

    Almost seems like video scraping is the issue. I'll try to confirm that tonight. I plan on just scraping the whole system rom folder to get image and video. Whichever ones have hack-link I'll delete the just scrape for images only and see if checking video download is the issue.

    I really want this to work normal for me again. While USX seems good and I like it, it's painfully slow. Ran for a day and a half and still wasn't done, close but not quite done. In my limited experience Sselphs is very fast but with USX I do know that I have everything I need.



  • I noticed the same thing but it seems like it was pretty consistent for me. Always the Super Mario World or Mario related titles.



  • I wonder if Nintendo hired hackers to hack the data on screenscraper servers



  • @pickaxpete yes, my scraping was images only, no videos.



  • I scraped my roms again last night for images and videos and had similar results. It was much worse before but most things worked well this time. Some rom folders had a few hack-link images. There were 2 that were completely filled with that, atari 7800 and nes. That's as far as I got last night. I'll scrape those tonight for just images only and see how it turn out.
    Either way I'll probably just use the USX scrape data for those 2 and edit the gamelist with find and replace in notepad++. Seeing how sselphs is set to put all that in the respective rom folders and I prefer that, I'll just modify the paths and be done.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.