Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sselph scrapper getting strange results



  • This is why I use UXS, it scrapes based on the hash, it doesn't care what the system is as screenscraper will tell it what the system is from the hash.

    I don't understand why sselphs one is system limited if it is using screenscraper as the source.



  • @squeez52, I tried sselph again yesterday, no luck. Downloaded UXS and ran it on one rom folder on my PI and worked great. Now I'm scrapping my rom folders on my PC and will transfer the gamelist and images over to my PI when it's done. Seems to take a lot longer than sselphs scraper but it looks to be getting all the images and video snaps. Gamelists I've checked look to have all the correct info as well.


  • Global Moderator

    @bladehunter said in Sselph scrapper getting strange results:

    it scrapes based on the hash,

    In fairness, sselph scraper uses hashes too:
    [ from https://github.com/sselph/scraper ]

    An auto-scraper for EmulationStation written in Go using hashes. [...]
    The script works by crawling a directory of ROM files looking for known extensions. When it finds a file it hashes the ROM data minus any headers or special file formatting with the goal of hashing only the data pulled from the original game

    There is an issue opened on the Github project page which mentions this problem (https://github.com/sselph/scraper/issues/214), so maybe this problem will be fixed.



  • Sselph scraper is working fine for me. I've just scraped some large romsets from scratch (finished half an hour ago) and I can't see any strange entries.



  • @tashman After I read your comment I tried it again. I still get mixed results on my end. I only tried it on some of my rom folders though. Most of those pulled down images and video fine. 2 out of five still grabbed the hack-link image. I scraped gb, gba, gamegear, jaguar which only have a handful of games in them. Those could have been the ones that were mostly good last weekend, I don't remember. The weird thing is when i scrapped videos for atari 7800, the whole folder was hack-link. When I turned video scraping off and just scraped images, the images and descriptions were good in the gamelist and image folder.

    Almost seems like video scraping is the issue. I'll try to confirm that tonight. I plan on just scraping the whole system rom folder to get image and video. Whichever ones have hack-link I'll delete the just scrape for images only and see if checking video download is the issue.

    I really want this to work normal for me again. While USX seems good and I like it, it's painfully slow. Ran for a day and a half and still wasn't done, close but not quite done. In my limited experience Sselphs is very fast but with USX I do know that I have everything I need.



  • I noticed the same thing but it seems like it was pretty consistent for me. Always the Super Mario World or Mario related titles.



  • I wonder if Nintendo hired hackers to hack the data on screenscraper servers



  • @pickaxpete yes, my scraping was images only, no videos.



  • I scraped my roms again last night for images and videos and had similar results. It was much worse before but most things worked well this time. Some rom folders had a few hack-link images. There were 2 that were completely filled with that, atari 7800 and nes. That's as far as I got last night. I'll scrape those tonight for just images only and see how it turn out.
    Either way I'll probably just use the USX scrape data for those 2 and edit the gamelist with find and replace in notepad++. Seeing how sselphs is set to put all that in the respective rom folders and I prefer that, I'll just modify the paths and be done.



  • Quick update.

    I went through and cleaned up some of my rom folders and deleted all game lists and downloaded images on my PI. ES scraped ones and sselphs. I ended up running sselphs and turned out pretty good. 1 snes was hack-link which I expected, zelda parallel worlds. Which from maybe my reddit post, hack-link is the default screenscrapper image when it can't find a image. Another system, forgetting now, had maybe 10. That one has good videos and images but the name was hack-link. Switched it and was good. Nes did have a good amount but did actually download correct images and video. I noticed that most were showing correct info but in the game list the <name> was hack-link. Changed it and was good, it was just the name display that was wrong for most.

    The ones left that didn't work and were fill the the psp hack-link name and info looked to be duplicates /versioned copies of a game. For instance super mario, super mario [a1], super mario [a2]. That might not be an exact example but a similar scenario. As I find them I'll fix them manually.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.