Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Select and start to exit game still not working



  • This worked in retropie 4.2. I've updated to 4.3.10 and configured controller ps3. When I get to hotkey option I press the ps button. Then exit then go into a game let it load then I pressed ps button and select and it doesn't exit. I've tried this in 30 emulators and it doesn't work in any of them.

    Also my keyboard won't exit a game with q and w which is set to select and start.

    Only way I can exit a game is r1 r2 select +start which takes me to retroarch menu then I quit retroarch and it takes me back to the game list screen.

    Is there a definatley way to get back start + select to exit game as none of the comments has worked for me thanks


  • Global Moderator

    @moonston333 said in Select and start to exit game still not working:

    Is there a definatley way to get back start + select to exit game as none of the comments has worked for me thanks

    Yes, when asked for a Hotkey button in the controller mapping screen, skip it and choose Yes when asked if you want to use Select as your Hotkey.



  • @mitu hi I did do that and then I restarted the pi loaded a game but still doesn't work I reconfigured my keyboard and put c as hotkey.
    This works press c and then w

    But seems like a hotkey can't and won't work on my ps3 controller don't know why

    All of the buttons are assigned apart from the ps button


  • Global Moderator

    @moonston333 Does it work if you disconnect your keyboard ? The RetroArch controls (hotkey and RGUI) I think they're only available to player 1, so if your keyboard is player 1 it won't allow the controller to take over.



  • @mitu yep I disconnected the keyboard reconfigured the ps3 pad loaded game and still doesn't work baffling me now don't know why it won't work as it should



  • @moonston333 last resort was to reburn an image. N e 1 has same problem all I did was access my pi3 from my pc and copied 2 folders emulationstation and gamelists. Then got basic 4.3 retropie image 2gb burnt it to 16gb sd then booted up pi extended storage and now the hotkey works fine ps button + start exits game.
    Then just installed all emus from retropie setup all working fine thanks for help



  • I'm having trouble mapping my controller now too after update. Can't exit games without using the keyboard. Ugh, problem solved!



  • Just adding a follow up here in case it helps anyone out finding this. I had the same problem of Start and Select not working but this thread made me realize what was going on. I had assigned the PS button as the hotkey thinking that made sense.

    The "Hotkey" is what needs to be used along with start to exit out of a game. So by default it's "Select." So pressing "Select" and "Start" exits the game (as we know). If you set the hotkey as the PS button, you need to press that AND "Start" still.



  • Well, starting off the ps3driver is pretty good and if you want the default Hotkey(PS_BTN)+Start then this won't be a problem;

    However if you want to assign custom hotkeys to retroarch, if you do this with the controller plugged in, it will assign the button number manually and these will differ than if you connect wirelessly with the ps3 controller. You can always press start on a retroarch option to reset it to its default(auto) value, where it will find the start and hotkey buttons automatically and not reference an arbitrary button number from its disconnected duality.

    There is a solution to this without transcribing the root configurations to bend the systemdaemons to your will.

    In the RetroPie management package drivers there is an alternative, the sixaxis helper driver. Installing this will uninstall the ps3controller driver and replace it. The arbitrated button numbers for wireless and connected will be as one and you can configure input mappings peacefully.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.