Please do not post a support request without first reading and following the advice in

  • Hello, some psx games are sometimes slow (like tekken 3 or crash team racing). But FPS-ingame always are at 60 even during lags. Can it be a sd card problem? Maybe is it too slow? It's the 16gb transcend class 10 that i found in the official kit of Raspberry. It's name is TSRASPI10-16G. I don't have another sd to test it. I tried both Recalbox and Retropie, same problem! Please help me!

    P.S. I have Raspberry Pi 3

  • @jekodark
    Good day. I know this may seem like a silly question, but are you using heat syncs and/or a case fan to assist in cooling? The processor will throttle itself down when it gets too hot.

  • Try disabling vibration from the quick settings menu.

  • @jekodark I had the same problems with a class 10 transdisk, A 1tb hdd seemed to fix the problem. With that said there are allot of other reasons from filters down to controller vibration just like pjft said. I don't want to be the one with the least helpful answer but if it is the SD then you could try another SD or usb stick, maybe even a usb hdd.

  • I disabled vibration and also i tried another sd, same problem. On the Raspberry I use 3 heatsink, so temperature is not the problem.

  • @jekodark try updating lr-pcsx . This was an issue around the time the last retropie image was made.

    1. Disable high resolution mode if you have it enabled.
    2. Some PS1 games do need the Pi overclocked slightly to run at full speed.
    3. NTSC games generally run better than PAL.
    4. As @pjft said, try disabling vibration, as this has been known to cause slowdown in the past.
    5. Does the audio stutter? Many PS1 games had framerate drops on real PS1 hardware. CTR is one of them: it drops below 30fps at the starting lineup, at the winner's podium scene and occasionally when there's a lot of activity on certain tracks. What you are seeing may actually be accurate emulation.

    Finally, the FPS counter in lr-pcsxr is how often RA is pushing frames out, not the internal framerate of the emulated PS1. There is no way to display that value in lr-pcsxr. However, only three (if my memory serves me) PS1 games ran at 60fps. Almost every game was locked to 25 or 30fps and many dropped below that at times.

  • You got me curious about Tekken 3. It is one of the few games that runs at 480i. According to a quick Google search it runs at 384x480 interlaced, a resolution that no other PS1 game seems to use. Not sure how lr-pcsxr handles it. Gonna have a look.

  • Well, in Tekken 3 with Enable interlacing mode(s) enabled there are pretty obvious combing issues, but I'm not experiencing any slowdown at all.

    With interlacing mode off I can't see any obvious quality difference, and it seems to run perfectly, even with enhanced resolution enabled.

  • If anybody comes accross this: Happened to me with version 4.6 (on raspbian buster), exactly same problem, like 3fps on all PS1 games. Tried different emulator (removed lr-pcsx-rearmed from main packages and tried pcsx-rearmed form optional). That ran well, but didn't see controller. So I decided to tweak with original lr-pcsx-rearmed, reinstalled it back and voilaaa, games at full speed. Don't know the reason, but for somebody just wishing running emulator it's worth trying I suppose.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.