Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Mupen64plus not installing & Dolphin not loading



  • Pi Model or other hardware: (B, B+, 2 B, 3, X86 PC etc..):
    OS: Ubuntu 16.04 LTS(x64 I think)
    CPU: AMD FX 770k
    GPU: AMD R7 240
    RAM: 8GB of generic DDR3 @ 1333MHz
    HDD: 1TB WD
    PSU: 400W generic powersupply.

    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.3.5
    Built From: Installed into Ubuntu 16.04
    USB Devices connected: USB Mouse and Keyboard
    Controller used: None yet
    Error messages received: I only have an error message regarding Mupen64,
    Could not successfully build mupen64plus - n64 emualtor MUPENn64Plus (GlideN64/projects/cmake/plugin/rekease/muoeb64plus-video-Gliden64.so not found)
    Log found in /dev/shm/runcommand.log (if relevant): /home/austin/RetroPie-Setup/logs/rps_2018-03-18_143341.log.gz
    Guide used: Followed the guide for installing on Debian/Mint/Ubuntu that is provided here https://github.com/RetroPie/RetroPie-Setup/wiki/Debian
    File: GlideN64/projects/cmake/plugin/rekease/muoeb64plus-video-Gliden64.so
    Emulator: Mupen64Plus & Dolphin
    Attachment of config files: https://pastebin.com/8GubB5bA

    How to replicate the problem:
    Install a fresh version of Ubuntu 16.04 LTS
    Doing a quick apt update and upgrade
    apt-get update/upgrade
    Downloading RetroPie via command line
    Go through the basic install set up
    At the end it appears with this message:
    Could not successfully build mupen64plus - n64 emualtor MUPENn64Plus (GlideN64/projects/cmake/plugin/rekease/muoeb64plus-video-Gliden64.so not found)

    I tried this 3 times on new installs on the same system and the same error had occurred. All other emulators seem to work fine other than Dolphin which will give me a blank screen for a moment and returning back to the retropie Wii/Gamecube screen.


  • Global Moderator

    Most likely there's an error during the compilation of Mupen64Plus, but the details are in the logs stored in /home/austin/RetroPie-Setup/logs/rps_2018-03-18_143341.log.gz. Unpack the file and then upload its contents to a site like pastbin.ubuntu.com or pastebin.com.



  • @mitu I accidentally placed the pastebin of the log where the config files are supposed to go. But I ended up figuring out what the issue was. Something on the system wasn't updated I guess and wasn't allowing for it to build correctly. All is good on the Mupen side. However I am still having issues with the Dolphin emulator. The test games in question is Pokemon XD Gale of Darkness and Super Smash Bros Brawl. When trying to launch either of these it gives me a "Dolphin emulator launching" sort of screen like the rest of the emulators, but then goes back to the game select screen. Do you think you could offer any help there or should I create a separate post about that?


  • Global Moderator

    I don't use Dolphin since it's not available for the Pi, but you might want to open a new topic for it.



  • @mitu Alright, thank you for your help!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.