Please do not post a support request without first reading and following the advice in

GamepadBlock not being seen by PC or Pi

  • after wiring up my gamepadblock and connecting it to the pc to test; it doesnt come up as anything. I have my dip switchs at 000, I'm using arcade buttons and a 4-way joystick. I've tried different cables, etc. i also tried to update the firmware but when I run the .exe it just opens a commandline window and closes immediately. Running windows 7, and the led on the gamepadblock itself turns on indicating that its being powered. Any help would be appreciated, thank you!

  • Global Moderator

    The update tool is a command line tool. In Windows you need to open the command line and call the tool from there. You can find a screencast at I would be interested if the update tool can communicate and update your GamepadBlock.

    Also, does Windows or the RPi see a gamepad, of you change the dip switch to 001?

  • so, I did end up getting it to work, Turns out that the jack on my particular gamepad block is a bit finicky (maybe defective?) but after jiggling it around I got both my PC and my gamepad block to see it. As for the update tool, I did try to call it from the commandline and even then it would still close itself instantly or would not give me access (even when running cmd as Admin) but after jiggling the wire a bit; the update tool and the gamepad block seem to work fine on both platforms. Very strange. Thank you for your help, I really appreciate this community.

  • Global Moderator

    Do you mean that you needed to firmly press the USB cable into the connector to solve the issue?

    Anyway, glad to hear that things are working for you now!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.