Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Video previews not working correctly with custom game collections added.



  • Pi Model or other hardware: 3B
    Power Supply used: 5v 2.5a
    RetroPie Version Used : 4.4
    Built From: Berry boot image from this site
    USB Devices connected: wireless keyboard/mouse combo

    I decided last night to scrape video previews for my collections through steves scrapper. Once it was finished scraping i tested it out and found that nes and n64 were working but if i went into snes the videos would be black with no audio. If i would then go back to nes or n64 they would also be black and would require restarting emulation station. I verified that i had omx player enabled and tested with different themes with the same results. I read that is could be a possible vram setting issue and tried it from 50-200 with no help (the higher i went it would start to through glgeterror 0x505). I also read that it may be related to a possible encoding issue, so as suggested i recoded all the snes videos using handbrake. This was also unsuccessful. I started playing around with settings and noticed that if i turned off the 2 custom game collections i had enabled (desktop, kodi) then all the videos seemed to play with no more black screens. I'm wondering if anyone has experienced this and was able to find a fix or solution.
    Thanks!


  • Global Moderator

    @matt-teix Omxplayer has problems playing some video formats and the solution is to re-encode them. You can check this by switching to the VLC video player which - while slower - will be able to play them.



  • @mitu I’ve tried recoding them with no change. They all work perfectly unless I add any custom collections to the menu (favorites, last played, Kodi, etc). With all custom menus disabled there is no issues.



  • I'm suspecting you're running out of video memory.

    What's your GPU memory split (I'm assuming 256), what theme are you using? If you try it with Carbon, what are the results?

    I'd get VRAM to be set at 80 and would not change that.

    Anything else you may be running - music player, etc?

    When it gets to those stages, can you ssh into the pi and run:

    • top, and see if omxplayer is indeed running or not;
    • sudo vcdbg reloc, and see how much free video memory you have. Definitely send the logs from that over.

    A copy of your /boot/config.txt file may also help.

    Thanks!



  • @pjft Thanks, that does seem like what’s going on. I currently am running at 80 for vram and issue is present on carbon. As for the memory split and config file, I’ll have to check those after work and report back.



  • @matt-teix Thanks. If you're running Carbon, I'm a bit surprised that that's coming up.

    Do run the vcdbg command I posted and send over the results over pastebin.

    Thanks!



  • @pjft So ive verified my memory split is set to 256. Based on the vcdbg i am running out of memory. ive included my logs with custom collections enabled and with custom collections disabled along with my config.txt in the paste bin.

    https://pastebin.com/GRUVGK2n



  • @matt-teix I'm very much puzzled by all of this, but could you comment out that line with dtoverlay=vc4-kms-v3dand see if it improves after rebooting? Why exactly do you have it there, out of curiosity?

    If you can send over your entire config.txt file, it may help. I'm not sure why it states that it's only using 140MB of GPU mem yet there's no more available memory, if you're using 256.

    Thanks.



  • @pjft I’ll try and comment it out and see. Honestly I don’t know why that’s in there as that’s what was in there from setup, I haven’t played around with the config.txt on this build yet. What I supplied in the paste bin is my entire config.txt
    Edit: commenting it out made no change
    Edit: If i run vcgencmd get_mem gpu it only returns 160m?



  • @matt-teix I'm somewhat puzzled by both that line and the fact that your config.txt file only has that content, but I have a different config.txt file.

    I suspect that the issue is related to the memory split here.

    https://www.reddit.com/r/RetroPie/comments/66fskl/berryboot_config_file_is_different_from_what_i/

    http://imgur.com/a/VOmfs

    I don't know how to set it in BerryBoot, but that is exactly the same issue and symptom.

    These are the key:

    https://github.com/RetroPie/RetroPie-Setup/wiki/Memory-Split

    I'd comment gpu_mem and uncomment the 3 other and go from there.



  • @pjft sorry i forgot about the berry boot config.txt, this is it.
    https://pastebin.com/SijFaC9w
    As for uncommenting the other 3 gpu settings and commenting out the gpu_mem=256, it has seemed to do the trick. Videos no longer go black with custom collections added. If i run vcgencmd get_mem gpu now i get "gpu=256m" and running sudo vcdbg reloc shows "total space allocated is 236M"



  • @matt-teix Perfect.



  • @pjft Thanks for all your help, I really appreciate it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.