Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[IGNORE]Keyboard has completely stopped in Emulationstation



  • EDIT : I reflashed my SD card with a backup image from 4 days ago and redid the exact same steps below but it worked this time. No clue what happened but it's all good.

    ~~Pi Model or other hardware: Raspberry Pi 3 B
    Power Supply used: CanaKit 2.5 A supply
    RetroPie Version Used: 4.4
    USB Devices connected: keyboard / 128GB USB stick
    Controller used: 8bitdo
    Error messages received: N/A
    Log found in /dev/shm/runcommand.log (if relevant): no file present
    Guide used: https://github.com/RetroPie/RetroPie-Setup/wiki/8Bitdo-Controller
    How to replicate the problem: Constant

    So my keyboard isn't working in EmulationStation anymore. It works fine in the terminal AND I can hit F4 to exit EmulationStation.

    Here's the rundown:

    • I bought myself a SNES30 controller. So before I tried to install it I uninstalled the PS3 driver and rebooted.
    • I updated the SNES30 controller to 4.10 from the 8bitdo site.
    • I ran through the setup instructions listed here.
    • I rebooted the system as instructed in Step 17 and got back to EmulationStation.
    • When EmulationStation loaded I powered up the SNES30 and got the solid blue "connected" light. (I did not try the keyboard first since it didn't even occur to me to try it at this point).
    • Nothing worked after that. The controller didn't do anything (no surprise as I didn't configure it yet) but my keyboard isn't doing anything now either.
    • I tried rebooting without anything connected except the keyboard and it still isn't right.

    Is there a way to force the system to reconnect my keyboard? Delete a config file or some such?~~



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.