Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Dualshock controllers on 4.4 with 3B+


  • Global Moderator

    @chrisjpark So, what's the actual problem you have ? The cat command doesn't run games, so if you maybe explain what your exact problem it might help to find a solution.



  • @mitu the problem is that when the DS4 controller is connected it does not recognise the other controllers for player 2 within games. However is have just done some more testing and the problem appears to be fixed. However the cat command still shows the motion sensors as being active. Maybe that is normal behaviour though and I am just misunderstanding.



  • Thanks for this! It worked great after using SSH and creating the rule in Retropie. I did have to reconfigure the controller layout after reboot.



  • Hey guys, first: i'm new to the world of retropie, so please be patient:)
    I followed the instructions above, but it didnt fixed the problem of the motion sensors.
    I looked for the rule, whether it is saved or not.

    pi@retropieTU:~ $ sudo cat /etc/udev/rules.d/51-disable-DS3-and-DS4-motion-controls.rules
    cat: /etc/udev/rules.d/51-disable-DS3-and-DS4-motion-controls.rules: No such file or directory

    So i am wondering why the rule isn't saved. i pressed strg+x, pressed y, then strg+c, strg+x, n
    Is the rule saved this way?
    Is there any other way to reboot instead?


  • Global Moderator

    @th0mi Did you get any error while trying to save the file ? Remember you'll need to run the editor as root, so start it with

    sudo nano /etc/udev/rules.d/51-disable-DS3-and-DS4-motion-controls.rules
    

    then enter the text and afterwards save it.



  • There wasn't any error. Can't remember the right wording yet, there was something like "File saved at/as..."

    I started it with sudo, is there something to else to consider that i run the editor as root?
    I am gonna make a screenshot of if in a few minutes.




  • Global Moderator

    The path looks ok - you can check if the file was created with the command

    ls -l /etc/udev/rules.d/51-disable-DS3-and-DS4-motion-controls.rules
    

    Do you have an original Sony DS3/DS4 or something else ? The configuration is specifically for those controllers.



  • I did everything on this post, but my raspberry still recognizes the motion sensor as a device.



  • @Madcaplaughs I can confirm that this works on ps4 dualshock 4.4 internal bluetooth 3B+

    If it's not working for you, there's a chance you put the file in the wrong directory. As this is a new file, it would be very easy to think you did it right and create a new file.. but in the wrong place. Again, I am NOT using a dongle. I AM using ps4 controller bluetooth internal. The exact problem in this thread was the issue. Two controllers showed up per controller. And it was exactly this, the motion sensor counted. When I disabled it, everything fixed.

    PLEASE make sure you ar using the correct fix as he originally posted the wrong thing. See below

    @rsn8887 said in Dualshock controllers on 4.4 with 3B+:

    Here are the corrected instructions. I tested this and it works for me. Emulationstation sees only one controller per DS4 and AdvanceMAME does not react to controller motion events anymore.

    ssh into your RetroPie

    enter

    sudo nano /etc/udev/rules.d/51-disable-DS3-and-DS4-motion-controls.rules

    paste the following into the editor

    #disable DS3/DS4 motion controls
    SUBSYSTEM=="input", ATTRS{name}=="*Motion Sensors", RUN+="/bin/rm %E{DEVNAME}", ENV{ID_INPUT_JOYSTICK}=""

    Hit CTRL-x and y to save

    reboot and verify that motion controls are disabled. For example Emulationstation should only detect 1 controller per DS4 etc.

    Also, please be sure you have updated your system so we know you're using the same versions/packages as everyone else. Be sure to reconfigure the controller after reboot as well. The button bindings may need to be reset. Lastly, you can use various programs (discussed in other forums) to test your controller keybindings, then compare them to the controller config file. Keep in mind the ps4 bluetooth using internal shows up as "wireless controller" and not dualshock



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.