Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr mame2003 - double inputs with IPAC2



  • Is there a way to stop lr-mame2003 reading both the keyboard and the Retropad (which is also the keyboard)? I'm getting double inputs when I try to bind a key because of that. I searched and found a post about setting all the retroarch bindings to "nul", which works but then I can't navigate the Retroarch menu. Is there a cleaner way?



  • I also had a hard time with this despite following everyone's advice of carefully setting keybindings in retroarch vs mame. My problem was that on a vanilla install, my IPAC2 keybindings were overlapping / conflicting with the MAME's keybindings.

    To fix this issue, I ended up flashing my IPAC2 controller with a new bios from Ultimarc that sets up the IPAC2 to be 2 controllers instead of a keyboard emulator. It worked beautifully and made things WAY EASIER with retropie.

    Hope that helps!



  • mame2003-plus has a new input mode specifically for this purpose.

    It is activated via a core option which allows the core to process input through the either mame_keyboard interface or the retropad -- or both simultaneously as with classic mame2003 (although that is not as useful as you are finding out).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.