Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

A noob needs help to fix controller configuration in Retroarch please.



  • Alright somehow when i go to any emulator i open retroarch , click quick menu, then click controls, under load remap file, save core remap, and save game remap instead of it saying ''User 1 B: B '' like it use to it now says ''Auto : 1 (N/A), (Key: Z) Button 2''.

    I know very very little just how to play/ add roms and scrap images for the roms. I assume when i updated today things changed somehow.

    That probably makes no sense i'm sorry about that. But in this video

    at 1:08 mark on is what i'm trying to return to.

    Or it can't be done and i need to start over again to make things right?

    I tried to figure this out but i'm not so smart

    .

    Thanks for the time.

    Pi 3 Model B
    Power Supply used: official pi 2.5v
    RetroPie Version Used: 4.3
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: wifi, keyboard
    Controller used: Logitech F310 gamepad


  • Global Moderator

    So what exactly is the problem here ? The new message that's shown or are you not able to re-configure your input using the RGUI ? Please give more details about what you're trying to do and why it's not working.

    The new input configuration is part of the new RetroArch versions, so that's normal if you upgraded (version 1.7.3 was added to RetroPie recently). Probably a lot of video tutorials like the ones you linked are now out-of-date due to this change.



  • This is a copy paste of a reply I did on another thread
    Took me awhile to understand how the new reconfigure work. Basically it makes more sense if you switch to Xmb interface from rgui, cause it will show you the player numbers. So Now it’s showing you the controller button on the left and and what you want it to be in game on the right. Opposite of what it used to be. But the way retropie auto configs , it’s showing the auto config controller number and not the retropad letters. Don’t fret. There is an order. It’s. Y B start select dpad A X L1 R1 L2 R2 L3 R3 and then the analogs. The advantage now is that you can have multiple buttons press one button in the emulator, or disable a button completely, like to disable the mame menu in mame2003 for example. Or disable turbo buttons if you want



  • @mitu well i was hoping to get my control configure settings to return to for example '' User 1 B: B '' like it use to be instead now ''Auto : 1 (N/A), (Key: Z) Button 2''. It's a pain in the ass to configure now trying to figure out what button is what haha. I regret updating now. Thanks for the reply Mitu!



  • @lostless May i ask where i switch to Xmb interface from rgui setting please? I changed the menu to Xmb and i'm still lost, only seeing for example in controller configure '' Auto : 1 (N/A), (Key: Z) Button 2 ''. Easy for some people makes it harder on other people like me haha. Thanks for the reply Lostless.



  • @dan18774 you need to restart retroarch to see the xmb menu. Should look like a PS3 or psp menu



  • @lostless I quit Retroarch after i switched to Xmb interface and re entered to see if i could see if anything changed in the control configure. It was the same as rgui interface just with ps3 layout like you stated. Thanks for the help Lostless.

    I had feeling nothing could be done when i created this thread. But had hope there would be quick fix to get it back to previous controller configure settings in Retroarch. Guess that is not possible.



  • @dan18774 I’m sure the retroarch guys will clean it up. They did with the old interface and I saw how it improvedover time. Now that I’m looking at the new way, it is better. I now like the ability to disable buttons, like the annoying 6 button switch on the pc engine emulator. It’s just the interface needs to be cleaned up a tad. Showing the Y (left), etc, will be helpful to come back.



  • @lostless Changes are apart of life haha. Most have been a problem i was totally oblivious of. Glad you like the update, i'll just have adapt. Thanks for even understanding what i was trying to explain and taking the time to reply Lostless. I expected zero replies to my question honestly. Have a great weekend!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.