Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Problems with Zero Delay Arcade Buttons Setup



  • So I just bought some arcade buttons with a usb zero delay encoder.
    I have a weird bug where retropie thinks I'm still pushing button that I pushed once after pushing it briefly. This results in bugs like megaman always charging his buster or mario always jumping to the maximum heigh.



  • @retroboii Is this one button, or all of them? If it is one button, It could be the button sticking.



  • No that's actually with every button (Joystick works fine though). Here is an exemple if I never pressed the select button since I launched the game and pressed the button start once it will work fine but if I pressed it after pressing the button select once (not simultaneously) Retropie will see it as if I pressed the select button and start at the same time and will return me to the main menu.



  • I guess the first thing to do is see what your encoder is outputting when you press a key. Try using jstest, the joystick test utility. Go to the command line and type in jstest /dev/input/js0 and then check what output you are getting from your buttons.



  • Another thought. Does your encoder have an "Auto" jumper, and if so, is anything connected to it? On my encoder, if this is connected, as soon as you press a button, it will autofire (simulate multiple button presses) until it is disconnected. That could be your problem.



  • @douga First of all thank you for helping me I think we are getting closer to the problem so I used jstest/dev/input/js0 in the command line every button worked fine there when I release a button it will go from on to off it isn't stuck like in the games.



  • @retroboii said in Problems with Zero Delay Arcade Buttons Setup:

    @douga First of all thank you for helping me I think we are getting closer to the problem so I used jstest/dev/input/js0 in the command line every button worked fine there when I release a button it will go from on to off it isn't stuck like in the games.

    do you mean the actual buttons or the joystick if its the joystick switch it to four way and youll be good



  • @grant2258 When I used jstest/dev/input/js0 both worked fine when I release the button retropie knows it's being released but I use them in a game like let's say super mario brothers, When I push a button mario will directly jump to the maximum even if I briefly pushed the button.



  • @Retroboii That's a good start, we can probably eliminate both the buttons themselves and the encoder as the source of the issue. To state the obvious, this sounds like a controller configuration issue. Which emulator are you using when you have these problems? I have the same Dragon Rise encoder, and i had a couple of issues getting it to configure correctly too, though not the same issue as you are having.



  • @douga Well to be honest I thought the same the configuration didn't work at first. For button to be mapped, I needed to push a button multiple times or wait a couple of seconds for it to be mapped it is not as snappy as mapping let's say a keyboard. I tried with an Snes,nes and even neo geo all of them had the same problem (I couldn't even use the neo geo one because you need to push select to put a coin then start to start but as said retropie sees brief push of a button as a me still pushing it that means when I push start it percieves it as Start+ Select which makes me return to the title screen)



  • @Retroboii OK, well you may well have confused the system by pressing buttons too many times, so the next thing to do is try reconfiguring your controller setup. If you can't get to them through RetroArch due to the button issue, go to the command line and delete the configuration files you find in /opt/retropie/configs/all/retroarch-joypads and reboot. Then as soon as it detects your encoder it should ask you to configure. I'm a bit surprised that the configure process is slow, it ran at a reasonable speed for me.



  • @douga tried that erased it. the buttons still work in the menu but don't work anymore in the game. I didn't get configuration option when I booted the system (the first time neither pushed start and then configured it alone). Anyhow is there another way to configure them ? what did you do exactly?



  • You should have a configuration auto-created because the buttons and joystick are working. It should be called dragonrise.cfg or something similar . Go into it and edit manually according to the instructions here:
    https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration

    To work out which button is "9", "3" etc, use the values that you get from jstest/dev/input/js0. I am not near my system now, but I will try to go in and pull up my configuration so you can see it.



  • This is mine. The file is called "DragonRise Inc. Generic USB Joystick .cfg", and can be found in /opt/retropie/configs/all/retroarch-joypads

    input_device = "DragonRise Inc. Generic USB Joystick "
    input_driver = "udev"
    input_l_btn = "1"
    input_load_state_btn = "1"
    input_start_btn = "8"
    input_exit_emulator_btn = "8"
    input_down_axis = "+1"
    input_r_btn = "7"
    input_save_state_btn = "7"
    input_right_axis = "+0"
    input_state_slot_increase_axis = "+0"
    input_select_btn = "9"
    input_left_axis = "-0"
    input_state_slot_decrease_axis = "-0"
    input_l2_btn = "6"
    input_up_axis = "-1"
    input_a_btn = "5"
    input_b_btn = "4"
    input_reset_btn = "4"
    input_enable_hotkey_btn = "9"
    input_r2_btn = "0"
    input_x_btn = "3"
    input_menu_toggle_btn = "3"
    input_y_btn = "2"

    and my es_input.cfg file, that you can find under /opt/retropie/configs/all/emulationstation looks like this

    <?xml version="1.0"?>
    <inputList>
    <inputAction type="onfinish">
    <command>/opt/retropie/supplementary/emulationstation/scripts/inputconfiguration.sh</command>
    </inputAction>
    <inputConfig type="joystick" deviceName="DragonRise Inc. Generic USB Joystick " deviceGUID="03000000790000000600000010010000">
    <input name="pageup" type="button" id="1" value="1"/>
    <input name="start" type="button" id="8" value="1"/>
    <input name="down" type="axis" id="1" value="1"/>
    <input name="pagedown" type="button" id="7" value="1"/>
    <input name="right" type="axis" id="0" value="1"/>
    <input name="select" type="button" id="9" value="1"/>
    <input name="left" type="axis" id="0" value="-1"/>
    <input name="up" type="axis" id="1" value="-1"/>
    <input name="a" type="button" id="5" value="1"/>
    <input name="b" type="button" id="4" value="1"/>
    <input name="x" type="button" id="3" value="1"/>
    <input name="y" type="button" id="2" value="1"/>
    </inputConfig>
    </inputList>



  • @douga Thanks I will try that but I kind off encoutered a weird problem after trying the erase the file as you told me the gamepad now only works in the menu. I made backup of the file and put it there again but the problem is still there , I tried configuring the gamepad again same problem



  • You are trying to configure the gamepad through the menu, and it isn't detected, ie through the "configure input" option here?
    0_1527174829828_bfb8922b-9d17-4152-a49f-cb72d7b41063-image.png



  • @douga Yeah I did it though the configure input and it works correctly but only in the menu when I open a game it says Dragon rise controller not configured .



  • Did you try copying mine? There is a space after "Joystick", so make sure you use exactly the same name as I have. If you have tried, can you post a copy of your file here, so we can have a look and see if we can identify what is wrong?

    I am definitely not an expert, so maybe someone else can help too.

    When I configured min in RetroPie 4.3, all of my buttons worked except one, and it took a while to work out what was going on. By the way, which emulator are you using?



  • I tried what you said the controls did change and became like yours we have the same model it seems as I didn't need to change anything when copy/pasting. But the same old new problem remain I can't use it in any game I get this message here is a screen shot (I tried uploading the files it says I don't have enough privilege to do so here so I uploaded them on google drive https://drive.google.com/open?id=1y8H-auVaOTZFNtXO1sCHrHZq2PT2A3hm )I tried the controls on the snes/nes/neogeo/gba on retropi 4.4 0_1527189347975_33592049_1777994502239605_5937587983715663872_n.jpg



  • Have you tried removing the inputs for the keyboard from your es_input.cfg file? Other than that, yours is identical to mine. I only use MAME2003 so far, and I was able to add coins, start game etc without having configured my keyboard.

    I will check the message I get from the controller when I boot up tonight, but I am sure it doesn't say not configured



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.