Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Problems with Zero Delay Arcade Buttons Setup



  • You deleted the folder or the file?

    I checked what my controller says when booting a game, and it says 100%: Dragonrise inc. Generic USB joystick configured in port #0

    Another thought. Do you have xpad installed? To check, go to
    RetroPie Setup -> Manage Packages -> Manager Driver Packages and look for xpad(installed)



  • @douga I deleted the folder and after that I put it back there when I made new configurations in retropie new files were created in it. I search for xpad(installed) found it and updated it from source sadly it didn't fix my problem.



  • @Retroboii OK, Iwe should try clearing out your joystick configuration and starting again from the default.

    First quit Emulationstation (press F4), then run
    sudo ~RetroPie-Setup/retropie_setup.sh
    Go to Manage Packages -> Core Packages -> EmulationStation -> Configuration and select "Clear/Reset Emulation Station input configuration". Then restart emulation station or reboot.
    After that configure your joystick, but for now leave the keyboard unconfigured.

    This suggestion came from a post by @jretropie about a year ago.



  • @douga So I've done some research yesterday I kind of found some extra informations to help us fix this problem. First I found out when I made a fresh install of Retropie on an other sd card and plugged the controller it will work in the games (but with that pressed button bug which makes it unplayable sadly) I tried putting your control configs there but it gave me the not configured bug , so I tried doing the opposite putting the new control configs and es input of the fresh install in my old install. it sadly didn't fix the problem either. Btw I discovered too why it took so long to map the controls in config as I told you the first time it was because every press was considered a long press which when configuring make retropie skip the button you're configuring . 1/5 presses are considered a normal one so I had to mash every button to get it to be configured.



  • @retroboii

    While researching last night, I saw someone else had the same problem as you, and in that case they also had the keyboard configured as a game controller first. It may be that putting the keyboard there first is messing things up a bit.

    What differences do you see between the config file with the original problem and the ones that I provided?



  • guys update your system (use binaries) and try again its the retropie setup
    -> update installed packages. reboot when done



  • Great news ! I fixed the hold button problem I actually wired the wrong part as the sensor has 3 outputs weirdly enough the one you find on the top only output long signals and no brief one anyhow everything worked fine on my new install now I simply need to fix the new problem of not configured on my old install (worst case scenario everything from the old install to the new install) and sorry for the late response it took me a lot of time to fix everything as the wires were wired pretty tight anyhow I'm going to test the new fixes you guys posted



  • Great, I hope the solutions work, otherwise we can keep on working on it :-)



  • So I did what you guys told me and it worked !
    I updated the core / main Packages and then I updated the system and then I reinitialized the configurations and now everything works fine! Sadly I don't know which one resolved the problem as I did both and then tested anyhow thank you guys for your support in particular you DougA you're a great guy ! Now I'm going to set my second arcade controller whish me good luck ;)



  • @retroboii Good luck! I’m glad you sorted it out in the end.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.