Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Weird keyboard problem



  • Hey everyone. I have a problem with my wired keyboard. The letters work fine but the symbols are switched with each other. Pressing @ gives me " for example. Did I set up my keyboard wrong? I would appreciate any help.

    Thanks



  • The default keyboard layout is the UK one, just reconfigure your keyboard with raspi-config and it should be fine.



  • RetroPie uses the UK keyboard layout I believe. I used this advice I found on Reddit to change mine to US.

    From the command line enter sudo raspi-config. This will bring you into the Configuration Tool. Choose option 4 Localisation Options. Change to your preferred settings... EDIT: Choose Option 11 after choosing 4. Change Locale. Then pick en_US.UTF-8 UTF-8.



  • I tried this but its still not working. Any other suggestions?

    Thanks



  • @sixstring396 if I am remembering this right, you can install another locale, but you still need to SELECT it for it to take effect. Does that sound right? I seem to remember that one of the items in the long list has an asterisk by it which is the selected one being used.

    <EDIT> Yeah, here is a site describing what I mean. You hit spacebar to select the locale. That page has commands to bring up these screens, but this is all accessible through raspi-config


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.