Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

HDMI to VGA Adapter: Audio Issue



  • I realize that the most logical fix to my problem would be to buy a different hdmi to vga converter with audio and try that out. Before I do that, I thought I'd post here just to see if there is any possiblity that a configuration / driver setting could possibly fix my problem.

    Here's what's happening. I have a retropie (rpi3b running retropie 4.4.) powering my arcade cabinet that has an lcd monitor in it that is vga only. I purchased this hdmi to vga adapter that I also use for my audio out as opposed to the 3.5mm jack.

    When I power on my retropie, all is quiet until around the time the retropie splashscreen comes on. At that time a loud crackling, hissing, static noise starts playing very loudly through my speakers that are plugged into the vga adapter. That sounds continues and never goes away until I load an actual game. When I select a game to play, the noise instantly goes away and the game audio is absolutely crystal clear and sounds fantastic.

    The static noise never comes back after loading an initial game and it ONLY happens on a hard power cycle. I also noticed that if I let retropie boot into ES and immediately do a "Restart System" from ES, the noise stops as soon as the soft reboot stops all of the retropie services. On the reboot, the sound never comes back!

    The symptoms of the noise starting only when Retropie starts to load and that instantly goes away on a soft reboot, made me think it's possibly a driver issue somehwere? It's worth noting that I have used the 3.5mm jack before but prefer using the hdmi audio because I find it to be a much cleaner audio source.

    Any ideas? Any help is most appreciated!



  • @loggahead did you remove the # in front of hdmi_drive=2 in /boot/config.txt? If not try that.



  • This post is deleted!


  • @edmaul69 I enabled hdmi_drive=2 last night and it didn't make a difference. It's weird because at first it seemed like that setting helped. I kept power cycling my pi to test it and the noise would only play for about 1 second during boot up and then it would go silent. After being off overnight, the noise was back in full form this morning when I turned it back on.

    I also noticed that in addition to doing a soft reboot in ES, if I do a system shutdown from the ES menu, the noise instantly goes away. At that point, if I powercycle my pi the noise doesn't return.

    I dunno. I've had this pi for a couple of years now and before I restored my arcade cabinet, I just used it hooked up to a tv and it never once gave me an ounce of a problem which still leads me to believe something is off with that adapter.


  • administrators

    @loggahead Try the settings detailed in the documentation - https://retropie.org.uk/docs/Sound-Issues/#white-noise-fix



  • I ended up just going back to the 3.5mm jack for audio in my cabinet. Based on the linked article, I just made sure I had the following settings in my config.txt:

    disable_audio_dither=1
    audio_pwm_mode=2

    For some reason my pwm_mode was set to 0 in my config and changing that to 2 resolved all my issues with the 3.5mm jack.

    Unfortunately, I was never able to get the crackle / hiss / static noise issue resolved when sending audio out HDMI to my HDMI to VGA adapter.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.