Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie can't reset my keyboard



  • Hi,
    I have a slight problem with my retropie setup and am wondering how to remedy this. I am trying to reset my keyboard after my esc couldn't exit emulators so I thought hey why not bind it on the menu. Big mistake. Only my keyboard works on emulators and not the controller. I tried setting a hot key for the controller and going through retropie setup to fix it. None of those worked. The pad I have works fine in emulation station but not in the emus. I don't know what to do.


  • Global Moderator

    @polish-potato Your keyboard is probably set as Player1 and the emulators use it instead of the controller. If you unplug the keyboard, does this make the controller work in emulators ?



  • But, I want to use the keyboard as an exit. I just don't like using hot keys on a controller cause sometimes I exit by accident. It's annoying but that's what I want.


  • Global Moderator

    @polish-potato First you should determine if I was right - does it happen because the keyboard is detected as Player1 ? For the 2nd part - exiting with the keyboard - it depends on the answer to the question.



  • @mitu yes. I can't exit with the controller or keyboard and I'm really getting concerned how many times I tried to fix this and shut it off because I could not exit. It's ruining my new card.



  • I don't think you need to worry about ruining your SD card, if that's what you mean. Just don't pull the plug while the system has a green light on and you're fine. There's no moving parts in these systems to truly hurt.

    Try plugging your controller in the upper-left USB slot and the keyboard and/or mouse in the two on the right. When my controller has flaked out and been unresponsive I could still get out of a game by pressing ESC on the keyboard with them plugged in like that.


  • Global Moderator

    @ultrakev9 said in Retropie can't reset my keyboard:

    Just don't pull the plug while the system has a green light on and you're fine

    That's exactly what is happening, that's why @polish-potato wants to 'fix' this.

    @polish-potato I think the new RetroArch input configuration in 1.7.2 make it possible for assigning multiple inputs to the same player - see this post on the RetroArch forum. You could make the controller be P1 (for any system or for all systems) and disable the exit hotkey of the controller, enabling exit only with the keyboard.



  • @mitu I was able to get the hot keys to work on my controller but not the keyboard. I was able to get my controller binded in retroarch configs. The player one was on the keyboard but to tell you the truth no matter what I set it to in the input configs in retroarch for hotkeys I can't get the keyboard to work as it normally did.

    At least I have one controller working I just need the keyboard as my hot keys.

    Another thing, I can't access the menu after selecting a game. I can access it by hitting the keyboard but that is about it.

    How would you recommend I enable exit only with keyboard?



  • @polish-potato -- You're going to need to get in to RetroArch and unbind your keyboard as Player 1. That sounds like that's the big issue. I've never bound my keyboard as a controller and the ESC key works great at pulling me back in to Emulation Station.

    RetroArch will be your answer for binding keyboard keys as hotkeys ~instead~ of using your controller. I think you'll need to set the keyboard as Player 2 (or maybe 3 or 4) in order to get this to function properly as otherwise only the escape key will be recognized. This is from my own personal experience. Since many games don't have players 3 or 4 it sounds like 2 is the best bet.

    What kind of controller are you using? I found that using an Xbox 360, Xbox Elite or PS4 DS controller has that additional button in the center that normally calls up the menu on their respective systems and in Emulation Station it counts as another button that can be used for hotkeys. Obviously, if you're not in to that it sounds like binding the keyboard as a controller is your best bet.



  • It seems I may have found a solution. I don't know if I am crazy or not but I found a solution.

    I went into the retropie setup and went under retroarch keyboard configs and went under "Configure keyboard hotkey behavior for RetroArch." I pressed alt and now alt and esc are configured for exit of the emulator. Don't know if it'll fuck up again but we shall see.

    Another thing I am using a mayflash usb adapter for my snes controllers and after playing around with it I did not put it into player 1 it was in 2. It was some of the problem. It's not exactly labeled.

    I am just wondering about the other hot keys on the keyboard will come back? If they don't no biggie just as long as it works for the hardcoded stuff it should be fine. I wish I could save states on my keyboard but w.e.

    Thanks guys.



  • Nevermind solved the issue.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.