Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

EmulationStation stop display image & video in custom-collections



  • Hello,
    I found a strange behaviour in EmulationStation with Chicuelo Theme.
    I have custom collections.
    These are the step to reproduce issue :
    System Menu -> Go to "Custom Collections"
    My list of custom collections is displayed. I choose for example "Atari Classics"
    The list of games is displayed (all are "arcade" games with lr-mame2003).
    For each game, there is a scraped image and also a video. The theme display the image for 2 seconds, then the video is displayed.
    If I launch any games, and then quit retroarch, I'm back on the game list (Atari Classics), and this time, nothing is displayed. No image and no video. Same for all games in this list. If I go back to the custom collections list, same problem, no image/video displayed.
    If I go back to system view, and enter again the "custom collections", all is back as usual (images and videos are displayed normally).

    I only have this behaviour in the "custom-collections" system, there is no such issue for all others systems (especially in Arcade/lr-mame2003 - it works flawless).

    Any ideas perhaps ?
    thanks.



  • @cacrlhungus74 Sounds like a video memory problem. What is your video ram setting in Emulationstation ?



  • I think it is the default value of 100Mb.
    Just tried with 300Mb. Same issue.



  • @cacrlhungus74 It needs to be lower, not higher. Put it at 80 and re-try.



  • Same thing with 80mb.
    If it can help, I've got the exact same behaviour on my Retropie 4.4 on my Pi3B, and on a Retropie 4.4 on a ubuntu 64 bits machine.



  • Any errors logged in ~/.emulationstation/es_log.txt ?



  • Lots of line (mainly missing roms in collections).
    This is the moment when I launch the rom (720.zip in this case), and go back to the list (with no image/video)

    lvl2: Loading custom collection config file at /home/pi/.emulationstation/collections/custom-Taito Classics.cfg
    lvl2: req sound [video.launch]
    lvl2: (missing)
    lvl2: Attempting to launch game...
    lvl2: /opt/retropie/supplementary/runcommand/runcommand.sh 0 SYS arcade /home/pi/RetroPie/roms/arcade/720.zip
    lvl2: Creating surface...
    lvl2: Created window successfully.
    lvl1: Tried to enable vsync, but failed! (Negative swap interval unsupported in this GL)
    lvl2: req sound [video.back]
    lvl2: (missing)
    lvl2: Added/Updated 1 entities in '/home/pi/RetroPie/roms/arcade/gamelist.xml'
    lvl2: EmulationStation cleanly shutting down.



  • Does this happen with other themes or just with the Chicuelo theme ?



  • Try with carbon theme. Same thing. Videos are not displayed when back to list.
    When back to system menu and re-open collections, it works again.



  • Do you have power savings enabled? Can you send over your ES settings file via pastebin or something?

    I'm fairly sure I can't replicate that here, but I'm happy to look into it tomorrow. What ES version are you on? What do you need to do for a video to display again? Does navigating up/down work?

    Can you check if this still happens on the es-dev package?



  • Hello,
    Thanks for you reply.
    Power saver modes is disabled.
    This is my es settings :
    https://pastebin.com/mLsEFjQq

    To get the image/video working again, I must go back to the system carousel then enter again in the collection folder.

    This is a small video I've made :

    description :
    I enter "collections" menu, then highlight "Atari Classics" collections. You can see a video playing on the right.
    I enter "Atari Classics". You can see video for the titles I highlight.
    Then I launch APB, and exit it.
    You can now see there is no more video for the games titles. If I go a level up (collection level), the Atari Classics does not display video either. I go a level up again (system level) and by entering again in Collection, everything works again.

    EmulationStation is v2.7.5RP. I will check with ES-Dev.
    Hope this helps.



  • @cacrlhungus74 Thanks. Let me know how it goes with emulationstation-dev.

    The only differences I can spot on my setup are that I'm using OMXPlayer, and that my transition isn't set to instant.

    I haven't really tested it yet, but let me know if any of these settings change the behavior, and/or if it no longer happens on emulationstation-dev.



  • Hello, Got the same issue with ES 2.8.0RP-DEV.

    I try "Transition style = Slide" instead of "instant". Same thing.
    About OMXPlayer, I don't know about it, where it could be changed ?



  • @cacrlhungus74 Other Settings, I believe.



  • I perform these tests on my ubuntu machine. I don't see this OMXPlayer setting. Maybe only on Pi ?

    0_1531309654998_2018-07-11_13-46-24.png



  • @cacrlhungus74 Ah.

    Well, yes. I was not aware that you were not on a Pi.

    Let me look into this when I have a moment. Probably will take a few days.



  • I mention it on a previous post. (number 5 in the thread) :)

    But note the issue is exactly the same on the Pi and on the Ubuntu machine.
    That's why I took the liberty to perform tests on the ubuntu, it's more easy to make screenshots and so on...



  • @cacrlhungus74 I just tested it on my end, both omx and VLC, carbon and artbook themes, wasn't able to replicate the issue. While I did see your video, I have little more to work with here. Unless someone else is able to replicate it or has any more insights, it's a puzzle to me why this specific scenario would not work, and why it's different to launching a game in a subdirectory. Can you try the latter and see if it fails as well?



  • @pjft I just try to create a subdirectory (named level1) in my arcade folder, and another subdirectory (named level2) into the level1 folder, to have two sub-levels, like in the collections.
    I perform the same steps :

    go into "arcade" folder
    go into "level1" subfolder. Rom Video is working.
    go into "level2" subfolder. Rom video is working.
    Launch rom in level2 folder
    Quit rom
    Go back in level2 folder : video is still working.
    Go a level up : video is still working.

    So it seems something is different between the subdirectory and the collections folders.



  • @cacrlhungus74 interesting and puzzling at the same time.

    Once again, lacking anyone else looking into something similar, I'm kind of lost here.

    So, to confirm:

    • this happens on the pi as well,
    • with both omx player enabled and disabled,
    • in the default carbon theme,
    • only on the custom collections folder,
    • for any collection and game

    ...

    I'm truly stumped.

    If you launch the exact same game on its native folder all works well, I assume.

    You tested all these changes (vram, transition, power savings, etc) on the pi?

    For the sake of troubleshooting it'd be easier if we're focusing on the pi for now if possible.

    What image was this based on, if you don't mind me asking? Also, how did you create the collections?

    Edit: could you try a game without a launch image, if you have any?

    Thanks.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.