Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Hypseus new Daphne fork to try on Retropie



  • Hi
    Here is a new discus about Hypseus, a new fork of Daphne that Recalbox use.
    Some features that differ from the original version we use :

    • Updated MPEG2 decoder
    • Working MPEG2 x86_64 hw accel (SSE2)
    • SDL2 support
    • cmake build tool
    • More bugs!
    • Overlays have been implemented with SDL2 at last, but they need testing. So please test and report issues.

    With less bugs and overlays it can be a good update for Retropie to use it if it works fine.
    The original Daphne project is down from many years, maybe this one can fix our problems ...

    Recalbox wiki : https://github.com/recalbox/recalbox-os/wiki/Daphne-(FR)
    Hypseus git : https://github.com/btolab/hypseus
    Hypseus fork : https://github.com/grant2258/hypseus (the one we use for now)

    Install :

    Minimum software requirements: gcc, cmake, autotools, zlib, SDL2, vorbis and ogg.

    Connect to your PI in SSH
    Install these lib if not already done, for my part in Retropie all is already uptodate.

    sudo apt-get install libsdl2-ttf-dev
    sudo apt-get install libsdl2-image-dev
    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
    

    Get the source code and compile it

    cd /home/pi/src
    git clone https://github.com/grant2258/hypseus.git
    cd hypseus/
    mkdir build
    cd build
    cmake ../src
    make -j3
    

    Don't use the -j3 option if your PI is not ventilated, if not it will warm and freeze !

    Copy to Daphne directory the font, input ini and executable file.

    cp ../doc/hypinput.ini /opt/retropie/emulators/daphne/
    mkdir /opt/retropie/emulators/daphne/fonts
    cp ../fonts/default.ttf /opt/retropie/emulators/daphne/fonts/
    cp hypseus /opt/retropie/emulators/daphne/
    

    Edit the launch file /opt/retropie/emulators/daphne/daphne.sh and modify it like this :

    #!/bin/bash
    dir="$1"
    name="${dir##*/}"
    name="${name%.*}"
    
    if [[ -f "$dir/$name.commands" ]]; then
        params=$(<"$dir/$name.commands")
    fi
    
    "/opt/retropie/emulators/daphne/hypseus" "$name" vldp -framefile "$dir/$name.txt" -useoverlaysb 2 $params
    

    Compatibility list :

    Here is my compatibility list with the commands i can found over the web.
    You must put the command line in the GAMENAME.commands file in the game directory : /home/pi/RetroPie/roms/daphne

    • Astron Belt : -fullscreen -x 512 -y 480 -latency 950S -bank 0 00000000 -bank 1 01000000
    • Badlands : BLACK SCREEN -fullscreen -x 640 -y 480 -bank 0 00000000 -bank 1 10000010
    • Bega's Battle : BLACK SCREEN -fullscreen -x 512 -y 480 -bank 0 00000000 -bank 1 00000001
    • Cliff Hanger (2009 Restoration by Darryl Hirschler) : -fullscreen -x 640 -y 480 -bank 0 00000000 -bank 1 01000000 -bank 2 00000000 -bank 3 01111000
    • Cobra Command : -fullscreen -x 512 -y 480 -bank 0 11010000 -bank 1 00010001
    • Dragon's Lair : -x 640 -y 480 -bank 1 00110111 -bank 0 10011000
    • Dragon's Lair [Remastered by Accumbens (and Franck) to HD 720p the 15/02/2016] : NOT Smooth on PI -fullscreen -x 1280 -y 720 -bank 1 00110111 -bank 0 10011000
    • Dragon's Lair 2 (Enhanced v3.19) : Freeze on title screen after a long bip. The video parsing (.DAT) not working and crash Hypseus. I must do it with Daphne. -fullscreen -x 640 -y 480
    • Dragon's Lair 2 [Remastered by Accumbens to HD 720p the 12/03/2016] : NOT Smooth on PI impossible to play, -fullscreen -x 1280 -y 720
    • Esh's Aurunmilla : -fullscreen -x 512 -y 480
    • Firefox : Not working on Daphne BUT START on Hypseus Impossible to play, controls not respond, -fullscreen -x 640 -y 480
    • Galaxy Ranger : -fullscreen -x 512 -y 480 -bank 0 00000000 -bank 1 00000000
    • GP World : The road is freezing some time, impossible to play, -fullscreen -x 720 -y 480
    • Interstellar, Laser Fantasy : -fullscreen -x 512 -y 480 -bank 0 00100001 -bank 1 00000000
    • MACH 3 : Working but NO SOUND on PI like with Daphne -fullscreen -x 512 -y 480 -bank 0 01000100
    • Road Blaster : BLACK SCREEN like on Daphne, -fullscreen -x 512 -y 480 -bank 0 11111001 -bank 1 00100111
    • Space Ace : Launching fine, but FREEZE on title screen, -fullscreen -x 720 -y 480 -bank 1 01100111 -bank 0 10011000
    • Space Ace [Remastered by Accumbens to HD 720p the 31/03/2016] : NOT Smooth on PI, -fullscreen -x 1280 -y 720 -version ace_a -bank 1 01100111 -bank 0 10011000
    • Super Don Quix-Ote : The video parsing (.DAT) not working and crash Hypseus. I must do it with Daphne., -fullscreen -x 512 -y 480 -bank 0 00100001 -bank 1 00000000
    • Thayer's Quest : Launching fine, but like on Daphne (special) keyboard controls are not working. -fullscreen -x 640 -y 480 -bank 0 00010000
    • Us Vs Them : -fullscreen -x 512 -y 480 -bank 0 00000000

    BUGS TO RESOLVE

    You can found LOGs file in the Daphne directory /opt/retropie/emulators/daphne

    • How to hide the mouse pointer?
    • Fix all the games to works fine on PI like Road Avenger ...
    • Using SDL2 Joystick driver to solve the disconnect and configuration key
    • Or use SDL to let Hypseus using Retropie joypad configs
    • Adding border by game to hide black borders
    • Adding the SINGE engine for all the other games ...

    MAYBE A FUTURE UPDATE with SINGE engine

    An other DEAD project to port on PI with source code, or to add to Hypseus :

    To play Time Gal, and Ninja Hayate we must have the last Daphne source code on PI with SINGE 1.14 engine. It permit to play these games and the new Time Traveler game too. It'as a script interpreter that permit to make your own game if you want too.

    http://www.vincenzoscarpa.it/emuwiki/pmwiki/pmwiki.php?n=Emulatori.Win,Laserdisc&lng=en&r=1&w=1920&h=1080
    https://web.archive.org/web/20111025220646/http://www.singeengine.com/cms/
    https://web.archive.org/web/20111025175601/http://www.jaegertech.com:80/software/singe

    Full game list :

    • .38 Ambush Alley (Cop Simulator, Live Action)
    • Blue Thunder (based on 1983 movie Blue Thunder)
    • Hydrosub: 2021 (Underwater Future Sub Simulator)
    • The Rescue of Pops Ghostly (Haunted House)
    • Sonic Fury (Jet Game, included in system package)
    • Mad Dog McCree
    • Mad Dog 2: The Lost Gold
    • Last Bounty Hunter
    • Crime Patrol
    • Crime Patrol 2: Drug Wars
    • Space Pirates!
    • Who Shot Johnny Rock?
    • Time Gal
    • Ninja Hayate
    • Time Traveler

    And there is also the source code here that can be compiled on linux, never try to make it working fine on pi.
    It's only the 1.0 version, i don't found the 1.14 ???



  • On this channel you can see all the games the author of SINGE make works now ...
    But the project is abandoned or private and we can't have it and can't found the games too :(



  • Not sure if it's my roms, emulator or the hd versions of the videos, but they sure are buggy with skipping scenes on the pi. I haven't tried them on pc. Also, the 720p hd versions are way laggier on the pi. I hope if someone managed to compile this new version, if it'll help with at least the lag.



  • @darksavior I've compiled it you need to grab the two pull requests if using the orininal site. They are merged on my github page.

    I left instructions a while ago here https://retropie.org.uk/forum/topic/17884/daphne-shows-screen-tearing-on-raspi-3b-with-retropie-4-4/14



  • @grant2258 Thanks. Does the latest Hypseus version on your repo work on RetroPie on Stretch? Specifically curious about SDL and whatnot.



  • @grant2258 Thanks, that works. Dl1 and dl2 hd versions work. Though, it made space ace hd much worse. I’ll have to experiment with other roms but I suspect the custom video file might be the culprit. Road blaster/avenger still gets me a black screen, unfortunately.



  • Yes this was tested o stretch when I complied it. I'm not sure if pi supports the gl acceleration without the driver being enabled and the xorg. You'll need to ask the pi people



  • Finaly it works fine with this parameter -useoverlaysb 2 and i update the first post.
    I love the font he use :)

    The bad news for was that Road Avenger always not working with a black screen :(

    @grant2258 said in Hypseus new Daphne fork to try on Retropie:

    @darksavior I've compiled it you need to grab the two pull requests if using the orininal site. They are merged on my github page.

    Thanks a lot ... really cool to read that many programmers are working on this system :)
    I see you have 8 commits more than the original fork project :)
    To fix some games, SDL2 Keys and transparency.

    If i understand fine, i write here how to install your fork for every one :

    Connect to your PI in SSH
    Install these lib if not already done, for my part in Retropie all is already uptodate.

    sudo apt-get install libsdl2-ttf-dev
    sudo apt-get install libsdl2-image-dev
    export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
    

    Get the source code and compile it

    cd /home/pi/src
    git clone https://github.com/grant2258/hypseus.git
    cd hypseus/
    mkdir build
    cd build
    cmake ../src
    make -j3
    

    Don't use the -j3 option if your PI is not ventilated, if not it will warm and freeze !

    Copy to Daphne directory the font, input ini and executable file.

    cp ../doc/hypinput.ini /opt/retropie/emulators/daphne/
    mkdir /opt/retropie/emulators/daphne/fonts
    cp ../fonts/default.ttf /opt/retropie/emulators/daphne/fonts/
    cp hypseus /opt/retropie/emulators/daphne/
    

    Open this file opt/retropie/emulators/daphne/daphne.sh and comment the Daphne command line and add the Hypseus one to try it :

    "/opt/retropie/emulators/daphne/hypseus" "$name" vldp -nohwaccel -framefile "$dir/$name.txt" -useoverlaysb 2 -homedir "/opt/retropie/emulators/daphne" -fullscreen $params
    

    I let the -nohwaccel parameter for the moment, like you write GL is not supported ?

    I use my keyboard or my joystickup, not modify your hypinput.ini and it works almost like with Daphne.

    I have try some games and :

    • Astron Belt works fine with Daphne, go out with Hypseus
    • Badlands & Bega's Battle, same black screen than Daphne
    • Cliff Hanger works fine
    • Dragon's Lair works fine
    • Dragon's Lair HD, 2, 2HD are going out, they works fine with Daphne.

    I don't try the others ...

    Do you will to continue working on this emulator ? No one work on it from many years ... :(

    • It can be cool if all the games can be fixed to works fine on PI.
    • If we can use the SDL Joystick Retropie config like other emulators.
    • Maybe using the overlay to add a border by game to hide black borders ?
    • One day some one adding the SINGE engine for all the other games ...

    Thanks



  • @darknior Dl1 custom hd by “franck” is the one I tried. It works. I also tried my conversion and that works. I found a converter that converts from dl1 hd dvd iso to daphne 640x480 4:3. Under 900MB and it looks as good as “Franck’s”. I had to specify -x 640 -y 480 otherwise daphne will stretch the image.

    Dl2hd worked for me as well. I used the “accumbens” or something release.

    Space ace hd by “accumbens” I think, was a mess along with huge slowdowns in parts. It was acting wonky before with shortened scenes and scenes continuing even after dying. On hypseus I was skipping levels. I’ll try an sd version later.



  • @darksavior Thanks a lot for your tests :)
    But that's strange because all my games working 100% fine with the official Retropie Daphne.
    I make my pack some month ago and try many versions to have all of them working fine, SD and HD.
    And the second strange thing was i use same games like you from "Accumbens" ...

    • Astron Belt : Come back to ES before launching Hypseus, i know it because my background music script not muting music. He never found hypseus on TOP command.
    • Badlands : Same black screen than Daphne
    • Bega's Battle : Same black screen than Daphne
    • Cliff Hanger : Working fine
    • Dragon's Lair : Working fine
    • Dragon's Lair [Remastered by Accumbens to HD 720p the 15/02/2016] : Come back to ES
    • Dragon's Lair 2 (Enhanced v3.19) : Come back to ES
    • Dragon's Lair 2 [Remastered by Accumbens to HD 720p the 12/03/2016] : Come back to ES
    • Esh's Aurunmilla : Come back to ES
    • Firefox : Come back to ES but no green screen like with Daphne
    • Galaxy Ranger : Working fine
    • GP World : Come back to ES
    • Interstellar, Laser Fantasy : Working fine
    • MACH 3 : Working but no sound on PI like with Daphne
    • Road Blaster : Black screen like with Daphne, hypseus is launched.
    • Space Ace : Launching fine, but freeze on title screen. I must kill hypseus with shell
    • Space Ace [Remastered by Accumbens to HD 720p the 31/03/2016] : Come back to ES
    • Super Don Quix-Ote : Working fine
    • Thayer's Quest : Launching fine, but like on Daphne keyboard controls are not working.
    • Us Vs. Them : Launching fine, i can listen the voices, put credits, but i can't play, the video is replace by a gray screen.

    I will try games from an other set to see if it's same ?
    And try to found your DL1 HD from "Franck's".

    Or maybe it come from my games launch command ? like them :

    Dragon's Lair 1 HD (dle21.daphne)
    -nocrc -noissues -nolog -noserversend -ignore_aspect_ratio -latency 950 -x 1080 -y 720 -fullscreen
    Dragon's Lair 2 SD (lair2.daphne)
    -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20
    Dragon's Lair 2 HD (lair2_319_euro.daphne)
    -nocrc -noissues -nolog -noserversend -ignore_aspect_ratio -latency 950 -x 1080 -y 720 -fullscreen
    Space Ace SD (ace.daphne)
    -nocrc -noissues -nolog -noserversend -latency 950 -x 640 -y 480 -blank_searches -min_seek_delay 1000 -seek_frames_per_ms 20 -bank 0 00000000 -bank 1 00000001
    Space Ace HD ()
    -nocrc -noissues -nolog -noserversend -latency 950 -ignore_aspect_ratio -x 1280 -y 720 -fullscreen -version ace_a



  • @darknior I think the accumbens rls of dl1 hd has the Franck mention.

    My tests were done from the command line with grant’s recommended settings. I’ll have to edit the daphne.sh for hypseus properly since dl1 hd got me a black screen but I could hear the audio.



  • check your error logs some of the old command line options dont work and you get no visual feeack on the console



  • @grant2258 I needed to add the overlay. That fixed it.
    @darknior Looks like using a clean framefile fixed my space ace hd issues. The rest of its issues might be rom related. I'm using the sae rom right now. It skips ahead even when losing. No continues.



  • @grant2258 said in Hypseus new Daphne fork to try on Retropie:

    check your error logs some of the old command line options dont work and you get no visual feeack on the console

    Thanks a lot.
    I've removed all the old commands from the games XXX.commands file, but it change nothing, always back to ES.
    I also edit the runcommand.log but it always write me same, game working or not ...

    Parameters: 
    Executing: /opt/retropie/emulators/daphne/daphne.sh "/home/pi/RetroPie/roms/daphne/astron.daphne"
    
    Parameters: 
    Executing: /opt/retropie/emulators/daphne/daphne.sh "/home/pi/RetroPie/roms/daphne/cobraab.daphne"
    

    Where can i found the ERRORS log?

    @Darksavior yes ... this system is really strange :(
    I lost many days to try many games versions for Daphne, update runcommands to make them better ... to have a good set, and now it not working fine on hypseus fork that use the same engine, i don't understand why :(
    Maybe we can share our command line of our working games to compare ? Some games (same version) are working for you and not for me ???



  • @darknior I'm using the command from grant's instructions: /opt/retropie/emulators/daphne/hypseus lair2 vldp -framefile /home/pi/RetroPie/roms/daphne/lair.daphne/lair.txt -useoverlaysb 2

    Delete your dats so they can be re-generated and delete any special command files.



  • @darksavior Thanks a lot i have make some more test and now it working really better :)
    I post here my progress before updating the first post.

    @grant2258 said in Hypseus new Daphne fork to try on Retropie:

    check your error logs

    Thanks a lot, sorry for the mistake.

    • I finally found the LOGs file in the Daphne directory /opt/retropie/emulators/daphne, you don't use the runcommand one ...
    • I don't found the solution to hide the mouse pointer. Is there a trick for it?
    • So bad the video parsing (.DAT) not always working fine and crash Hypseus. I must do it with Daphne. And it's better on Daphne to see this operation to understand the emu is not crashed but is working.

    Edit the launch file /opt/retropie/emulators/daphne/daphne.sh and modify it like this :

    #!/bin/bash
    dir="$1"
    name="${dir##*/}"
    name="${name%.*}"
    
    if [[ -f "$dir/$name.commands" ]]; then
        params=$(<"$dir/$name.commands")
    fi
    
    "/opt/retropie/emulators/daphne/hypseus" "$name" vldp -framefile "$dir/$name.txt" -useoverlaysb 2 $params
    

    Compatibility list :

    Here is my compatibility list with the commanded commands i can found over the web.

    • Astron Belt : -latency 950S -bank 0 00000000 -bank 1 01000000
    • Badlands : BLACK SCREEN -bank 0 00000000 -bank 1 10000010
    • Bega's Battle : BLACK SCREEN -bank 0 00000000 -bank 1 00000001
    • Cliff Hanger : -bank 0 00000000 -bank 1 01000000 -bank 2 00000000 -bank 3 01111000
    • Cobra Command : -bank 0 11010000 -bank 1 00010001
    • Dragon's Lair : -bank 1 00110111 -bank 0 10011000
    • Dragon's Lair [Remastered by Accumbens (and Franck) to HD 720p the 15/02/2016] : NOT Smooth on PI -bank 1 00110111 -bank 0 10011000
    • Dragon's Lair 2 (Enhanced v3.19) : Freeze on title screen after a long bip. The video parsing (.DAT) not working and crash Hypseus. I must do it with Daphne. No options.
    • Dragon's Lair 2 [Remastered by Accumbens to HD 720p the 12/03/2016] : NOT Smooth on PI impossible to play, No options
    • Esh's Aurunmilla : No options
    • Firefox : Not working on Daphne BUT START on Hypseus Impossible to play, controls not respond, No options
    • Galaxy Ranger : -bank 0 00000000 -bank 1 00000000
    • GP World : The road is freezing some time, impossible to play, No options
    • Interstellar, Laser Fantasy : -bank 0 00100001 -bank 1 00000000
    • MACH 3 : Working but NO SOUND on PI like with Daphne -bank 0 01000100
    • Road Blaster : BLACK SCREEN like on Daphne, -bank 0 11111001 -bank 1 00100111
    • Space Ace : Launching fine, but FREEZE on title screen, -bank 1 01100111 -bank 0 10011000
    • Space Ace [Remastered by Accumbens to HD 720p the 31/03/2016] : NOT Smooth on PI, -version ace_a -bank 1 01100111 -bank 0 10011000
    • Super Don Quix-Ote : The video parsing (.DAT) not working and crash Hypseus. I must do it with Daphne., -bank 0 00100001 -bank 1 00000000
    • Thayer's Quest : Launching fine, but like on Daphne (special) keyboard controls are not working. -bank 0 00010000
    • Us Vs Them : -bank 0 00000000


  • Update first post with all the informations for now.



  • @darknior DL1 HD, DL2 HD and Space ace HD are fine for me. I'm not using those extensions you're specifying like -bank, etc. As I said, try Grant's instructions first then tweak it from there.

    I did personally convert DL1 HD from a DL1 HD-Dvdrom iso using dlhd2daph which converts it to 640x480. I'm running everything at 720x480.



  • @darksavior I know and i use the same settings like you, have you read my command line in daphne.sh.
    -bank are same as dipsiwtch in arcade MAME games. To change the coin price and some other things ... it not change the game emulation. And i already use without anything, i put these settings because i try with and without them, and because there are the dipsitch commanded by Hypseus, Recallbox, Daphne and many other site.

    My games are not working because mine are in read HD 720p !!! not 640x480 and PI not reading them fine with the Hypseus MP2 i think.

    DL1 HD-Dvdrom iso using dlhd2daph which converts it to 640x480

    I don't do it, because i want to play it in real 720p HD (1080x720). The image is incredible in 720p, and i really wish to play them smooth one day.
    On PI3 if the MP2 codec is updated with hardware acceleration, OpenGL?
    Or on PI4 or Odroid X4 when it will come, with un bigger proc <3



  • @darknior The games were never supposed to be in widescreen. Accumbens/Franck's DL1 HD 720p (1280x720) rip is the cropped 16:9 version. Yuck. I haven't checked the other two yet but they look squished at 640x480 4:3 so that's why I thought 720x480 was the correct res. I converted my DL1 HD Dvd-Rom again to daphne with its original res of 1440x1080. According to the Space Ace HD Dvd-Rom iso I have, it offers 3 resolutions and 1440x1080 anamorphic 5:4 is the optimal resolution.

    Edit: 1440x1080 is not 5:4 but 4:3.
    I tried my own DL1HD 1440x1080 converted rip and it's unplayable. Too slow. So it is a resolution problem. Using the original 640x480 rip I did first works just fine. Trust me, the game still looks great and barely noticeable. I highly suggest you hunt down the original DL1 HD Dvd-rom but I don't think it's avail anywhere on the internet anymore. Unfortunately, there's no converter for the Space Ace HD Dvd-rom. I don't believe there's an HD Dvd-rom version of DL2. Bluray versions might all be cropped widescreen garbage.
    0_1531628118689_7RESOLUTIONMENU.jpg



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.