Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Error when updating RetroPie - Error running 'git pull' - returned 128



  • Hello,

    my setup:

    Pi Model or other hardware: 3B+
    Power Supply used: 5V 3A
    RetroPie Version Used 4.4.2 (1c476df7)
    Built From: Pre made SD Image on RetroPie website,
    USB Devices connected: No
    Controller used: Not relevant, SSH used for updating
    Error messages received: see below
    Log found in /home/pi/RetroPie-Setup/logs/rps_2018-08-17_210141.log
    How to replicate the problem: The problem is always there when I'm updating RetroPie

    I got the following error when updating my RetroPie via SSH using retropie_setup.sh (sorry for the few german errors, I think you get the idea, these are git-errors). I filtered the relevant lines and that you can see where they are.

    = = = = = = = = = = = = = = = = = = = = =
    Configuring 'retroarch' : RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators
    = = = = = = = = = = = = = = = = = = = = =
    
    fatal: Kein Git-Repository (oder irgendein Elternverzeichnis): .git
    fatal: Kein Git-Repository (oder irgendein Elternverzeichnis): .git
    [...]
    xmb/monochrome/png/core-options.png
    Copying new default configuration to /opt/retropie/configs/all/retroarch.cfg.rp-dist
    /home/pi/RetroPie-Setup/logs
    Error running 'git pull' - returned 128
    Error running 'git submodule update --init --recursive' - returned 128
    
    = = = = = = = = = = = = = = = = = = = = =
    Installing 'lr-atari800' : Atari 8-bit/800/5200 emulator - Atari800 port for libretro
    = = = = = = = = = = = = = = = = = = = = =
    [...]
    

    What could this be?

    Thank you!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.