Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-pcsx-rearmed does not start - Failed to load content



  • Hi everyone
    sorry if I repeat a long discussed topic. I just could not find a solution to this problem even after reading many posts and after trying several solutions.

    I am trying to run a PSX emulator on raspberry pi 3+ with a recent and fully up to date RetroPie installation.
    I have checked the es_systems.cfg file and it lists both PPSSPP and PSX emultator commands (I have installed both emulators however the PPSSPP is not listed).
    I have all BIOS files in place and I am trying to run an ISO rom (placed in the right folder). The correct BIOS for that rom is present and is efficiently LOADED by the lr-pcsx-rearmed emulator (as shown in the runcommand.log file).

    What happens when I load a ROM: the screen turns black and the emulator fails to launch. When I check the log file the only thing that seems not ok is the following: at the end of the file it says
    [libretro INFO] unsupported/invalid CD image: /home/pi/RetroPie/roms/psx/Crisis Core - Final Fantasy VII.iso

    however the format file is listed in the es_systems.cfg, the latest versions of the emulator have been installed (both from binary or source, neither worked). The rom works on PC using PPSSPP and epsx from RetroAarch (installed on PC not on the Pi). I have tried another rom which is also working on PC but it does not work on the Pi.

    It seems there is some problem loading the roms by the libretro-psx-rearmed emulator but I do not know how to solve this.

    updating the RetroPie system files does not help either.
    I would appreciate if you could suggest a solution I haven't tried so far.

    Thanks !



  • @obliv have you tried putting the game in the psp folder?

    Also I don't think it will run well..you can play 2d psp games pretty good, but the Pi has a lot of trouble with 3d psp games.



  • @bobharris It works ! I loaded the roms into the PSP folder instead of the PSX folder.... then ... pcsx rearmed simply does not work ?



  • @obliv As far as I know that is only for ps1 games. How well does crisis core perform on your Pi?



  • @bobharris it seems it runs well, now I am trying to transfer some save files from my PC - can't find the right pi folder now but I will update if I make it.



  • @obliv said in lr-pcsx-rearmed does not start - Failed to load content:

    [libretro INFO] unsupported/invalid CD image: /home/pi/RetroPie/roms/psx/Crisis Core - Final Fantasy VII.iso

    Thats a PSP game, not a ps1 game. PCSX-rearmed is for ps1 games.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.